NMEA-GGA Output to USB/Laptop

Dear List

I am looking for a possibility of getting the raw NMEA-GGA data-stream of a REACH-Rover over a cable (e.g. USB) to a Windows computer.
The strng sent should be the standard NMEA-GGA output (e.g. $GPGGA,100218.25,4722.0840200000002,N,00831.52682,E,1,11,1.0,300.317,M,47.969,M,*60).

Dou you have any idea, how I can get it done.

Looking forward to any hints.

Best regards,

1 Like

I use an NMEA output through the wifi connection of the reach, configuring as a tcp server, in the “Position output” option. But you can connect via BT, and USB, but I have not tried it.
I collect the data in QGIS.
Explain more what your project is to see how I can help you.

1 Like

Hi Yvo,

Here you can find more information about how you can output the position in NMEA in docs:


Dear And_Nz

Thank you very much for the fruitful input. I tried it out and it works perfectly using WiFi and the default port 9001.

But anyway one question more:
The main usage is to feed the NMEA-GGA Stream into the serial port of a measurement device. If possible using a direct connection between the REACH-module and measurement device. I tried to sketch it (see sketch below):

If possible I would like to connect directly between the REAM-Rover and our measurement device. Probably we have to configure our own cable.
On the side of the measurement device, we have a computer listing for COM-interops and dealing with the NMEA stream. In case of the EMLID output, we would have to filter for the data line containing the GGA-Output.

Do you see a possibility for that?

Looking forward to any hints.

Best regards,

Hi @Yvo_Weidmann,

Yes, it’s possible. You’ll need to set Serial to “USB-to-PC” and Format to “NMEA” in Position output tab in ReachView.

Hi @andrew.yushkevich

Thank you very much for the replay. Sounds good and I tried it out.

First I set the Output 1 to USB-to-PC as recommended and Output 2 to TCP-Server to check the output:

The output using TCP works perfectly.

In the Device-Manager of the computer I tried to find the Serial-Port to connect to. First, no serial port appeared in the manager. After adding legacy hardware, one COM port was visible:

Using PuTTY I tried to connect to the newly appeared COM Port with the following settings:

But unfortunately, PuTTY was not able to connect:

Do you have any ideas, hints or suggestions?

Looking forward.

Best regards,

Hi @Yvo_Weidmann,

It seems that you have a problem with Edison driver. Can you reinstall it?
After that, you should see the name of COM port like in the screenshot below.


Your settings are correct, hope that the first part of the message will help you.


Hi @andrew.yushkevich

Thank you very much for the replay. I reinstalled the current version of the Edison driver as you pointed out (version 1.2.1). As you mentioned, I got new COM ports:

Using again PuTTY and the virtual COM port I was able to connect to the data stream:

Thank you very much for the help. I works.

Best regards and a nice weekend,