New rtl8812au Wi-Fi dongles are supported now!

Hello guys!

From time to time we’ve been asked if the dongles with the abovementioned chip are supported.
Unfortunately, there’s no official Raspbian support for these at the moment. People needed to compile the driver themselves which might get rather tedious and perplexing.

That’s why we rolled out a temporary solution for this matter. In order to use any of these devices you need to perform very simple steps.

sudo apt-get update && sudo apt-get install rtl8812au-dkms

This will take a couple of minutes, so you’ll need a little patience :slight_smile:

I hope this is useful for anyone!

This was tested with ALFA AWUS036AC and a 5GHz network.

1 Like

Hi there,
I tested this driver together with hostapd: https://github.com/abperiasamy/rtl8812AU_8821AU_linux
Seems to work really smootly with Alfa dongles (if they get enough current).

This is the driver that was packaged. So I don’t expect any abnormalities. :relieved:

1 Like

@george.staroselskiy you’re my new personal hero. Thank you for making this so much easier.

Now… On to getting wifi broadcast working :stuck_out_tongue:

Why not just use the onboard BCM43438 WiFi chip in the Raspberry Pi 3 or is the above mainly for the RPi2 with an external dongle?

Great Job, thank`s a lot!

@Al_B rtl8812au is capable of 802.11ac and we’ve been constantly asked about its support.

Tried this one but am having some difficulty with the last command

I get the error Unable to locate package rtl8812au-dkms

Up until that point it’s working fine.

How do I fix this?
Can it be fixed?

Have you run sudo apt-get update beforehand? I tested the procedure and everything seems to be fine.

I did yes.

Tried both commands in sequence again and am still getting the same thing. First command downloads a heap of package files. Second command reads those lists, build a dependency tree, reads state info and then finishes with the error.

sudo apt-get install rtl8812au-dkms
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package rtl8812au-dkms

I’m running a Pi2 with latest firmware and the latest version of Raspian.

Could you please post the output of emlidtool?