New RS3 setup will not get a fix Lora/NTRIP

I think I exhausted all options trying to get my new RS3 work.

Setup up: 1x RS3 base 1x RS3 rover.

Rover will not get a fix no matter what correction method I tried. Lora, local NTRIP even tried rtk2go NTRIP (waiting for correction & never getting any, tried on both rover & base)

Clear skies no interference. Thus I am truly at the point of willing to smash both units against the ground & be done with it.

What I am doing wrong? Reinstalled Flow app. Put RS3 to defaults. I think I truly exhausted all possible solutions.

Any help or suggestions?

Or is it just a lousily designed product? If it is the case should I simply return both units? After 2x wasted days trying to get them working I am truly questioning this company’s ability to make a reliable product.

Hello Dan. Sorry for your frustration. But I can tell you that the Emlid units work great. But, from your description of what you have tried, it is not clear where things are breaking down for you. Have you followed any of the published documentation? If so, which configuration? Can you share the steps you have tried exactly?


Probably the same thing we all do from time to time, something so blindingly obvious we don’t see it.

Don’t despair, it’s all well designed and built and the most straight forward to get going out of anything I’ve ever used. But to achieve that simplicity the approach is slightly different to other environments you may have used.

As suggested send some details of what you have set up, Lora is more straight forward with less steps so maybe start with that.


Hi Dan,

We have received your email. Let’s continue our conversation there, as it may require sensitive information.

Fired both units up today & guess what? Got a fix.

Now I am at a loss as to why it was not work

ing for 2x days straight.

On a somewhat unrelated subject.

  1. Does anyone know why with rtk2go NTRIP not a single mount point is working? I tried Point One commercial NTRIP service, works with no issues, while rtk2go simply cannot find any mount point I tried.

  2. What would be the best practice for height coordinates in the Virginia area? Is NAVD88(GEOID18) superior to EGM2008? (using NAD83(2011) coordinate system)

  3. When RS3 disconnects from known wifi AP how long does it (should it) take for it to switch into hotspot mode?

Thank you

Regarding RTK2GO, do you have any quality assurance for the mount points you want to use? Because anybody and their mother can transmit corrections there and you have no idea if they were diligent in determining their base position.


Does your state geodetic survey office provide an RTN service ? That would be the most reliable and trustworthy. Ours in SC has a great RTN service provided by the SC Geodetic Survey and is really reasonable in cost, $600/year.

The other option would be to contact your states transportation office as they usually have a system.

Buying a subscription from a major GNSS manufacturer is a reliable source.

1 Like

Unfortunately, our state does not provide any services. Only commercial options. VDOT attempted to offer a public free NTRIP service but apparently, Leica & Topcon threatened to sue gov bc both companies have setup subscription-based services in the state.

1 Like

Last I checked, (believe it or not the last lousy 3 years) the good 'ol US of A prospers on Capitalism and free competition. Hell, Leica, based in Switzerland and Topcon, based in Japan, are foreign entities. Move forward VA, and while your at it, make it freely available via paid tax dollars like MN does. The rest of the states should follow suit too!

1 Like


I’m glad to hear you were able to receive corrections.

  1. As @Gabriel_C mentioned, RTK2GO is an open caster; anyone can set up a base and transmit corrections. This makes it difficult to troubleshoot the NTRIP issue from this particular NTRIP service.

  2. EGM2008 is a global geoid, so the accuracy is not as good compared to local geoid such as NAVD88(GEOID18). NAVD88 is the official vertical datum in the US, so it’s better to use this geoid for the survey.

  3. If the device disconnects from the Wi-Fi, you need to restart Reach to go back to the hotspot mode. After restarting, Reach will try to connect to any known Wi-Fi network and return to hotspot mode.