Need help getting ntrip corrections

Hi, I’m new here from Spain.
I 've received one Reach module last week. I’ve started to config my module, but I’m having some problems.

About wifi configuration ok…It’s easy (more or less). Then I enter on my “ReachView App”, select “config” tab, and there I can Start, Stop and change the config.
In my case I set the module as ROVER.

The next step is to choose the “positioning mode”… When I load the deafult single reach configuration, all it’s OK, I start receiving signal and I could see the status signal bars on the ‘Status’ top tab and also I could see how lat,long,height table is filled with an approximated location.

If I want get more accuracy on my location, I will have to set one NTRIP client. Then I select “Input source for base correction” --> ntripcli, and I fill with my data (IP, port, mountpoint, user, passwd). I save mi config and apply it, but on my satus tab no data is coming, not even a single status signal… no bars, “0” on my lat, lon height…

Anyone could help me what step I’m doing wrong? Help will be so much appreciated.


It sounds like you haven’t updated the Reach, this may help. After the update, the two buttons become one, Clicking the Same button to toggle On and off.

Hi @rep,

I have just tested NTRIP connection and it works just fine!

Is your Reach connected to a Wi-Fi network with Internet access?
Can you try setting everything up again and provide some screenshots?

1 Like

Thanks for your replies,

First I flashed my Reach Edison Firmware following theses instructions:

Then I got some little differences like start/stop in one button or also less fields in configuration tab. At this moment, I could get single status, but I was having the same answer when I set the NTRIP base corrections… Nothing.

Yesterday I tried it again and I updated the device using the ‘Update’ button on Logs tab. I could see how a blue led was remaining for few seconds and then I refresh the ReachView App and finally version v.0.0.2 appeared on this tab (Logs).

Then all things went better… For single reach configuration easy again and very fast. I tried again to set my NTRIP configuration and …finally I got FLOAT!!! :grin:
I was there waiting for a while…maybe for 15 minutes, but I couldn’t got FIX solution. Are there some advices to get FIX?

(screeshot from yesterday)

Today I will try it again, making some config changes…

Would it be possible to know how many satellites (total number) I’m tracking each moment? (obviously more sats than I could see on reachview bar status)


Hy Guys

I want to use the correction provided by University of Padua because I have access to ntrip service (i’m able to do this with my old lea6t and rtklib on my laptop)
but … I tried to configure my device but I’n not able to receive the info from base station

can you help me ?



Hi Francesco,
At the first, I would like to know if you have updated your Reach device or if you are trying to set it like your device arrived. In my case when we update the Reach device properly, I started to get corrections from the GNSS network which I was trying to connect. Before that, zero data. First I reflashed the Firmware ( and after I pushed the ‘update’ button inside the Reach AppView.

I am only using one device, I mean, I’m not usign one as base and other one as rover. I configure it as you can see on the next picture

I hope this could help you something.


thx for info
I tried to do same settings (with my credential) but how can understand if the message from base station is received from my device ?


inside the config tab you could use the output params, for example could create a file with NMEA output solution, or data raw, etc… Then you could see all NMEA received messages. By the way, when you are running your reach appview, if you are really getting corrections from your base station, I think you always will have to see some grey bars together green/yellow/red bars. Something like this

Hy Guy
attached the screenshot of my config
the same config works perfect with rtklib on laptopw
with reach app I’m not able to receive the correction
what’s wrong ?
maybe base correction ?


another little question
It is not clear for me if I have the laptop connected to the reach device using a wifi internetconnection is it possible to receive the ntrip correction over the internet ?



Hi Francesco,

When you are connecting to Reach Wi-Fi with your laptop it does not have internet access, this is why you are not getting data from NTRIP. You need to connect your Reach to Wi-Fi network with internet access.

Hy Igor
sorry i’m a little bit confusion

This is my situation
I have Ipad connected to internet then I open wifi connection I select the reach device so I’m able to open the reach app I set the ntrip connection
is it correct ?


In rtklib I can check if the ntrip works opening the ntrip mount point … and if I see the list I’m sure to receive the ntrip correction (in fact with mi old lea6t I can receive the correction in my area)


In this configuration internet connection is not shared to Reach. What you need to do is to create a hotspot on your IPad and connect reach to it. To achieve that:

  1. Open ReachView app and go to “Wi-fi setup”
  2. Manually enter credentials for IPad hotspot.
  3. It will not be able to connect right now because the hotspot on your Ipad is not active yet. It will remember the credentials for future use.
  4. Turn off Reach.
  5. Enable hotspot on your Ipad.
  6. Turn Reach on, it will see the known hotspot and connect to it.
  7. Now you are able both access ReachView using device_name.local and get NTRIP corrections.
1 Like

hy Igor
Be patience but…
Attached the screenshot of my ipad
is it correct wifi setting to receive the ntrip corection ?

if yes there is something wrong in the confiig

If not sorry but probably this step is too much hard for me …

I would like to explain what is my task

I want to output via bluetooth (i know that this part is ongoing) the solution nmea using the correction provided by ntrip
and I need collect the trajectory with reach mo

unted on my car.

thx for help



You are connected to Reach hotspot “reach:d1:5d” , which has no internet access. So your Reach is not connected to the internet and this is why NTRIP does not work for you.

You need to make your setup vice versa and make Reach connect to your IPad hotspot. I have provided step by step instructions above how to achieve that.

Hy Igor

thx for help finally I understood the problem (I’m not expert in wifi settings…) anyway can you suggest what is the best mount point for GPS and Glonass soltuion

provided by University in my area ?

see attach table

thx again


The one that is closest to you has GPS&Glonass and RTCM3 protocol.

in your last config screenshot I could see you had put “MAX3” as a Mountpoint to connect. That is a ‘Network solution’ but is not a single antenna… we didnt try if this kind of mountpoint works on reach yet or if only work with real antennas, when we will try it, we will post it here… Maybe today we will test some kinematic track with reach device and export it to kml file and we could see how accuracy with the map has the recorded track.

hy guys

can you suggest a mount point that works now with reach ?

do you think in the future will be possible to load the mountpoint list and select ?



Hy Igor
I try to setup the ntrip MAX3 mountpoint with rtklib on my desktop with lea6t module and I recevie fix (see bmp) but If i try to set reach with the same setting no result

Have you test if mount point max3 is supported by reach app ?