Need help for Joystick control problems

Hello guys, i’m putting my first build together and i want to get it work (at least hover) with my xbox one controller via MAVlink.
I don’t have an RC controller and the autopilot is connected via wifi
I managed to connect the gamepad to mission planner, assign the main channels and do the calibration; however i can’t control the copter (arducopter-hexa). When i try to arm the drone i get always rejected by the autopilot and mission planner says “rc not calibrated” even though the joystick is active and calibrated.
The main problem is that the autopilot doesn’t answer the joystick (motors doesn’t spin) and i can’t arm it because it says “RC not calibrated”.
Also every time i open mission planner and connect it to the navio it messages me about the new version of arducopter 3.5.5, but i did the updating of the autopilot.
Can someone tell me what to do or recommend me a post (i couldn’t find anyone with my problem)?
Thanks and sorry for my poor english

Edit 02/03/18
I managed to see it working trough bypassing the pre-arm checks (but i’ll find out how to get it with all the checks) and i’ve seen that the moment i arm the drone all the motors starts spinning at roughly 70% with the pad in the center. Most likely it’s a bad joystick calibration and i don’t know how to change the parameters manually as it sets those automatically within the calibration.

You will have to change the RC min/max values manually. If channel 1-4 are not changed from the default 1100-1900, the “rc not calibrated” warning will come up. You can find the RC parameters in the full parameter list. The next problem is the spring loaded throttle of your gamepad. Arducopter expects the throttle to be down for zero throttle output and you can not enter 1500us for zero throttle because this would trigger the rc not calibrated again (values need to be below 1300 and above 1700). You could later use throttle assisted flightmodes like althold, loiter, poshold etc. where the throttle needs to be in the middle, but for initial testflights it is recommended to fly in stabilize mode. The easiest would be to buy a cheap TX set or borrow one.

1 Like

Thanks a lot, i managed how to arm the hexa with the joystick “calibrated” (have to work more on the parameters).
The main thing is that the motors start spinning as i arm it no matter what value i put in the calibration, but i’ll work for that (or get an rc controller if i need secure flights).

The motors will spin as soon as you arm the copter. It is a safety feature, so you know the copter is armed and you can not accidently stop the motors while flying. If you want the motors to stop spinning after arming, set MOT_SPIN_ARMED to 0.

Yeah, i got that while trying to calibrate the ESC quickly, and realised i needed to do some math before putting random values in the calibration.
My configuration is:
-navio2 & rpi3 board
-s550 hexa carbon frame
-A2212 1000kv motors
-30A ESC
-3s 5200mah battery

The default parameters in the ESC calibration were
-MOT_SPIN_:MIN 0.150
and the whole drone weight is 1199.1g without battery and 1553.8g total, so like you can imagine they are pretty overpowered with a max amp draw of 10A per motor (T60 connector) and a needed one of 2.50-2.60.
I did some measurements of all the 6 motors at the point i required (250g), i can post them if are those are needed (heard that those motors are quite used because they’re cheap).
Anyway i’ll put the max gain at 0.400 as this gives the double power i need to really drive the drone. I saw how much the joystick mode (at least with the Xbox one controller) sucks as i can’t control it much.
But i want to try setting the sensibility very low and set the Esc gain as narrow as possible (between 0.08 and 0.35) but have to do some math for that too.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.