Navio2 Yellow LED Blinking doesn't connect to both mission planner and controller

After, supplying power with Li-po battery.
LED Sequence goes like below.

1)Green for 3 seconds.
2)LED turned off.
3)Yellow blinking 5~7times.
4)Red, Blue blinking quickly.
5)Yellow blinking twice turned off, yellow blinking twice turned off and so on.

  1. The problem is, this drone doesn’t connect to mission planner shows me " No Heartbeat Packets Received "

  2. Also,it doesn’t arm with controller.

Hello,

http://ardupilot.org/copter/docs/common-leds-pixhawk.html

Pre-Arm checks failed. If indoor with a GPS needed mode, or no telemetry link (check led solid green on your telemetry unit - no led on your picture), or bad compass health,…

Marc

If system refuses to arm, what can I do, for example, using another sd card etc???

  1. Bad compass health -> I think this one is the problem. I looked up on here(https://docs.emlid.com/edge/qgc/arming-checks/) and it says, if compass is currently calibrating, system refuses to system refuses to arm.

I actually was on the way of calibrating compass on mission planner, but found out it was lagging, so turned off mission planner on the process of calibrating compass.

  1. It should work with stabilize mode, indoor. However, should I go out?
  2. Navio2 starts with solid green and then shows the sequence I mentioned before.
    -> How can I check telemetry is properly linked?

Not recommended, but sometimes useful, to be used with caution (without propellers first), you can bypass pre-arm checks (all or part off). There is a setting in Mission planner for that.

Telemetry link:

At home and for all calibrations, use PiWifi UDP link. It is the best option

At the field, use telemetry units (see arducopter documentation for settings). Solid green light on telemetry module show good link between the two modules. Solid green + blinking red show traffic.

Marc

What I’ve understood from you is this below,

  1. Connect to drone(navio2+Raspberrypi3) by PiWifi UDP link or telemetry units.
  2. Find a pre-arm check bypass setting after connecting to Mission Planner.

My Question is, how do I connect with USB? Com4 port doesn’t show up when I connect with USB. Should I download a driver. If so, what driver should I download (?)

First and foremost, did I understand right?
Plus, if I use udp it shows"Waiting up for UDP."

Also, if I do with telemetry it shows this message “No heartbeat Packets Received”

For the driver, have a look at com drivers (my computer, properties, …), when telemetry unit USB is plugged, you should see something as USB Serial Port (COMxx).

Choose this Com port in mission planner, set the speed at 57600.

UDP connect: only with Wifi, work if /etc/default/arducopter UDP port IP is the good one (your computer IP) https://docs.emlid.com/navio2/common/ardupilot/installation-and-running/#specifying-launching-options

Marc

Hey there,

Have you followed the guide @mlebret shared in the last comment? You need to specify your GCS computer IP address in /etc/default/arducopter file.

The only way you can connect RPi to GCS computer with USB is over USB radio.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.