Navio2 video streaming errors

Navio2 RPi 3 b+
Rpi camera Rev 1.3
Mission Planner
Wifi connection


  1. Installed gstreamer1.0 from emlid link page (complete install)
  2. gst-launch-1.0 -v udpsrc port=9000 caps=“application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264” ! rtph264depay ! avdec_h264 ! videoconvert ! autovideosink sync=f\
  3. Result seems ok

Raspberry Pi
pi@navio: ~ raspivid -n -w 1280 -h 720 -b 1000000 -fps 15 -t 0 -o - | gst-launch-1.0 -v fdsrc ! h264parse ! rtph264pay config-interval=10 pt=96 ! udpsink host=<remote_ip> port=9000

-bash: my ip adress : No such file or directory
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn’t be enabled
mmal: main: Failed to creat camera component
mmal: Failed to run camera app. Please check for firmware updates

Blank is my pc ip adress
Can someone please help me?
I have no idea why the error messages are showing.
Thanks for your help.

Hi @joonyoung86,

Have you specified your PC IP address in host=<remote_ip>?

yes i already wrote my pc ip address but its showing the same error messages…
Thank you for your help :slight_smile:

is the remote ip for raspberry pi ip? not the pc ip address?

Hi @joonyoung86,

This message usually appears if there is a mistake in IP address. You should specify it in a format host=

As I see from the screenshot, you’ve entered something like host=<>

Remote IP is a PC IP address.

Please also share a hardware setup photo of camera connecting.

Thank you tatiana.andreeva. You are helping me a lot ^^
I fixed my simple mistake leaving < > with my ip.
I guess my ip problem has been fixed but still have problem with camera settings.

this is my hardware setting

Hi @joonyoung86,

Such messages appear when something is wrong with a camera connection.

May I ask you to run raspivid command? Please post the output here.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.