Navio2 telemetry issue

I am using default image for raspberry from Navio2 site. And I am on a last version of ArduPilot.

So I got some strange problem with my X-Rock telemetry. When I tried to connect to Navio2 from mission planner with UDP everything went fine, no problems at all. But when I am trying to connect with telemetry on MP with 57600 nothing happens, just a timeout and no heartbeat. I tried many thing, changing port in /etc/default/arducopter, with serial and other thing, tried changing baudrate, in Navio2 or in MP and even on telemetry, but still no heartbeat.

I have my telemetry connected to UART port on Navio2 (my wiring has only 4 pins, 5v, gnd, and TX and RX so no other 2 pins used). I am little lost here, may it be a problem with a telemetry? Or is it something to do with Navio2?
Telemetry is a this one:

Hi @vurdlok,

Welcome to our forum!

Can you please show a picture of how your telemetry is connected to Navio2? Is this radio recognized by your computer? If you work with a Windows-based computer, it should appear in the list of Device Manager.

Hello, sorry for timeout.
Picture is how recognized by my PC.

And this how it is connected:

Hi @vurdlok,

Thanks for the photos!

Can you please double-check that the TX wire from Navio2 goes to the RX wire on the telemetry and vice-versa?

If everything is okay, please leave only TELEM1 and TELEM2 in the /etc/default/arducopter file. Then, run sudo systemctl daemon-reload command. After that, enable ArduCopter and select COM10 in Mission Planner for the connection.

Let me know how it works for you.

Thanks for reply, but no, did everything as you said and nothing worked unfortunately :thinking:

Hello, I am working with Vurdlok with one drone, which is based on Navio 2, I did everything you wrote above, but unfortunately our telemetry dont want to send any information to ground station, I also check rx tx but it is right

We changed telemetry and did some research, so everything worked fine, anyway thanks for trying to help, have a great time.

1 Like

Hi @vurdlok and @Escargot,

Nice work! I’m glad to hear that you’ve figured this out. If anything else comes up, don’t hesitate to create a new topic.