Navio2 + Telemetry does not allow GPS Fix

Hi

I face a strange problem today.

I noticed that when I start Navio2 with a telemetry plugged to it, it will never be able to find any GPS Fix. Once I disconnect the telemetry from UART port, a few seconds the GPS Fix is found.
Then, if I put back the telemetry, the GPS continues to be fixed, but we lower satellites - but still works.
I repeated this experiment several times and always the same thing.
This problem does not happen with UDP connection.

Did any body faced the same problem?
Any explanation this fact?
Could be a problem of lack of enough power to get GPS fix when the Telemetry is connected?

Thanks
Anis

Hello,

Have a look at your antennas placement:

Deport the telemetry antenna, if you have enough clearance, you can position it upside down (towards ground).

If you have enough room, place your GPS antenna in a remote position, away from other electronic boxes.

Marc

Marc is correct, this looks like interference issue. Please try to separate antennas.

I did that, and I even put the GPS antenna as much far as possible from Telemetry antenna but always the same problem!
I repeated this several times with several ways, and always the same observation

My installation is not the cleanest one, but I have good GPS fix (15 to 19 sats and hDop around 0.7)

Marc

Anis,

You just wrote to support that the problem is the GPS antenna and of you swap it everything performs as it should?

Yes, this was a different problem.
I have an antenna that is not working at all. This is what I sent to support.

The problem I posted in this thread is different. It happened with me with the working antenna on both boards that I do have. I hope this makes it clearer.

I will try again today to see if I can get a GPS fix when the Telemetry is attached to the drone, but I tried so much yesterday and it is as I mentioned in the thread above.

What is the battery that you are using?

I also have the same problem. by lowering tx power on telemetry resolved the problem.but also sacrifice the communication range of telemetry less than 100m.

The battery on the picture is a small one (3S) for gimbal.

I fly with 4S-4500

Marc

This the layout of my copter


and still, I have the following when telemetry is on:

Disconnecting telemetry for less than 2 minutes and putting it on back I have the following

So, it seems it is a matter of interference and power.

Is there any means to overcome this problem?

Amila suggested to reduce the TX power the telemetry.
What is this parameter?

Thanks
Anis

I also have the same problem. I pulled my hair in frustration. The Navio2 gps seems to very sensitive to radio modems. My GPS is completely in front of my plane, Modem antenna on the tail, and I still get interference. :frowning:

Here are some pictures of my setup:
http://diydrones.com/forum/topics/my-ranger-757-3-build-with-navio2

I tried a separate BEC, half lambda dipole, ferrite cores, packing the modem in grounded aluminum foil. … no solid solution. Maybe a balun. But I don’t have the equipment to measure antennas.