Navio2 seems to be unreliable


i have a DJI F450 quadcopter with DJI ESCs and Motors paired with Raspberry 3 and Navio2 autopilot (and its original GPS and power module).
I have spent many hours and days trying to make everything work but its impossible. No matter what I have tried I always get this damn error messages like Gps Glitch, Error Compass variance, Unhealthy Gps etc etc etc and Mission Planner error messages flash like a christmas tree. I started getting insane.

I have tried literally everything. Upgraded Arducopter to latest version, reinstalled everything from the beginning several times, installed all hardware preciselly, used copper tape to all wires for unwanted EMI, used ground shield plates, foam on sensors, played with GPS parameters of arducopter to try several combinations according to others posts, calibrated sensors several times etc etc etc

I have concluded that the Navio2 has many bugs after seeing many other users recommending to stay away from it and use something more robust,
Before i switch to Pixhawk 6, i am posting and uploading my latest two (7.6 MB)
data logs from last flights i did today. If any other experienced users can see and understand the root of the problem, and its not Navio2 to blame, I would happily accept their recommendations.

I previously had a cheap APM board from Aliexpress and it was far more reliable and actually never had such problem on the same copter. I switched to Navio2 to make use of the Raspberry capabilities and I was expecting a huge improvement and not the opposite.

Thanks a lot in advance for any help and suggestions,

Hi @drone_newbie,

Navio2 is a highly customizable device. There are various of use-cases with Navio2 that influence the setup complexity. A lot of factors can affect the performance of the sensors and sometimes it’s hard to identify what causes the issue since there’re many components on the vehicle.

An issue with the GPS signal can be caused by incorrect environmental conditions and electronic setup. I see that you tried many things that we can recommend regarding the troubleshooting of GPS and compass issues. Still, it appears to me that some of the drone’s components affect Navio2’s sensors. I can suggest removing most of the drone parts and checking how the GPS and compass behave. If everything is working fine, then I’d be adding the components gradually checking whether the issue appears again. Thus, you can identify the possible source of the issue.

it looks like after changing the whole setup of my quadcopter (shielding everything that might cause interference , rerouting cables etc), everything seems quite stable. I will continue testing…

The latest raspbian image that you provide is for version Raspbian Buster…
Is it possible somehow to upgrade to the more recent version of Raspbian Bullseye ?? If yes, how is it possible ? Is it safe for the drone operation ?

Best Regards,

1 Like

Any chance to update to bullseye ?

Hi @drone_newbie,

Thanks for the update on this!

As for the image update, it’s hardly possible to do so since such an update requires additional changes that can be made only from our side.

Ok thanks…

Are there any plans to provide us with an updated image that uses the latest raspbian ?

Current image you provide is based on raspbian Buster but after this there have been 2 newer releases ( bullseye and bookworm)


1 Like

Hi @drone_newbie,

Thanks for the request but currently this is not what we have in our plans.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.