Navio2 RPi3 Wifi Direct Dongle

I want to connect to my Navio2/RPi3 using Wifi Direct (P2P).

So far, I have been able to get my TP-Link TL-WN722N working as a regular wifi device (wlan1), but the EMLID Raspbian distribution is missing the tools to set up P2P, and have been trying for 2 days now without success.

Any leads?

Many thanks,


Hello David!
Our image doesn’t really differ from the stock raspbian in terms of supported software. You’re free to apt-get install anything you would have with a default Raspbian.

We are trying to use the TP-Link TL-WN722N to set up a basic ad-hoc network between other raspberrypi/navio boards. We set up the interfaces file and it works with other dongles and it shows up in ifconfig under wlan1 but we can’t ping it or connect over SSH. Help please!

Hi Patrick. What image are you using? With me it was a plug and play issue. I used the beta of the latest Raspberry Pi image. You can find the final version 2016 03 23 here.

The previous image proved to be too difficult but git started with installing the driver from here.

Yeah we are using the most up to date navio2 image. It works with the alpha dongle, although the alpha dongle populated wlan0 automatically while the tplink populates wlan1, but we can ping or ssh the wlan1 adhoc network. any idea?

Running the iwconfig, we found the difference between the two dongles. With the tp-link, the mode is Manager and not ad-hoc. Why would this be? do we have to use wifibroadcast?

also using the iwconfig wlan1 mode ad-hoc doesn’t work, it says device is busy even if we call ifdown

dmesg could help us. I’m also interested how exactly you’re setting the whole thing up. I guess it’s udhcp + hostapd, isn’t it? If you can share the whole script it’d be lovely. I remember setting up TP-Link dongles using create_ap with -n switch. It kinda worked out of the box.

Its just a simple ad hoc network between raspberry pis. No udhcp + hostpad. Here are the changes we made to the /etc/network/interfaces file:

auto wlan0
iface wlan0 inet static
wireless-channel 1
wireless-essid MyNetwork
wireless-mode ad-hoc

I can’t ping or ssh into this network using the TP-link dongle because the mode is Manager

Take a look at create_ap. I’m pretty sure it’ll help.