Navio2 + RPi3 stack: unable to calibrate ESCs

Hey everyone,

I am new in the world of drones, and I am trying to create one using RPi3 + Navio2 as the flight controller, Mission Planner as my GCS, 3DR radio telemetry (M-Robotics SiK radio v2 915 MHz) connected via UART, and XBOX 360 controller as joystick. I am in the initial set-up mode and I believe I have correctly set-up everything but calibrating the ESCs; whenever I would attempt to arm the drone, I receive the following message: “error: command rejected by MAV.” I have looked up forums, the Navio2 docs, and nothing have worked so far. I am using the Stretch image provided by Navio, and ArduCopter version 3.5 (this is the only option under sudo emlidtool ardupilot). These are the steps I took to calibrate the ESCs:

  1. Remove the power wire (central/red) from 3 of the 4 ESCs’ servo wire
  2. Power the flight stack through USB micro of the RPi3 (ArduPilot is set to enable on boot-up)
  3. Connect ESCs servo wire on servo rail 1,2,3, and 4 (ESCs connected to PDB, which is not yet connected to battery)
  4. Connect flight stack to Mission Planner (baud rate: 57600)
  5. Enable joystick under Flight Data > Action > Joystick
  6. Calibrate radio under Initial Setup
  7. Still under Initial Setup, click on Calibrate ESCs
  8. Stop ArduCopter under sudo emlidtool ardupilot
  9. Set throttle on joystick to maximum
  10. Start ArduCopter under sudo emlidtool ardupilot
  11. Connect battery to PDB
  12. ESCs beeps, but no 2 beeps afterwards (I have also tried waiting for a solid 5 minutes for the 2 beeps, but nothing happened.)

Any help would be greatly appreciate it!

What reciver do you use?, picture of setup?
ESC spec?

The receiver radio I am using is the M-Robotics (3DR) SiK 915MHz radio telemetry connected to the Navio2 via UART cable. I am piloting the drone using an XBOX360 controller, aka joystick. And as for the ESCs: they are BL-Heli ESCs, continuous: 20A, burst: 25A, linear, BEC: 2A 5V, rated for Li-Po of 2S to 4S.

Also, how do you know if the ESCs have been calibrated? and if there’s anyway to reduce the latency of the joystick? Thank you very much for your help btw!

You still need to use your TX/RX for the setup and have it calibrated incase of emergency.
Did you follow this guide

I would do the following.

Connect all ESC’s to the controller and power.
Leave battery unplugged
Power up using USB ONLY
Calibrate Radio.
Using Mission planner select esc calibration
Unplug usb
Plug in battery and power on
After you hear tones from esc;s reboot

After that you can calibrate your Game pad

What do you mean by power up using USB only? As in power up the RPi3 + Navio2 flight stack using USB only?

You plug the usb cable in only

I tried it, but I’m not sure if it worked. How can I check if the ESC’s are calibrated?

I got a RC tx/rx, how do I use it to calibrate the ESCs? Is there a good step-by-step to follow?

Mandatory setup. And do every step in that order

Have you setup your pi to send telemetry to your groundstation so that you can connect

Yes, I have successfully connect to the on-board RPi3/Navio2 stack

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.