Navio2 RP3 PiCam v2 - gstreamer error in Windows

Hello, first post here.

I’m setting up my first build with a Navio2, Raspberry Pi3 and now a PiCam v2

But when I’m trying to run gstreamer on Windows, I get the following error:

WARNING: erroneous pipeline: no element “avdec_h264”

Any ideas?

1 Like

i might have worked out a different solution for you:
it has an very acceptabel delay and it is start and stop-able!
make sure you have netcat installed on rpi
sudo apt-get update
sudo apt-get install netcat

run on rpi: (for streaming over port 600 with a resolution of 800x600 and a bitrate of 1000000)
sudo raspivid -t 0 -w 800 -h 600 -b 1000000 -hf -ih -fps 20 -o - | sudo nc -k -l -p 600 -v

on windows pc:
install netcat (https://eternallybored.org/misc/netcat/)
install mplayer (http://mplayerwin.sourceforge.net/downloads.html)
easiest way to install to C:\netcat and C:\mplayer
run a command line

C:\netcat\nc64.exe 192.168.0.215 600 | C:\mplayer\mplayer.exe -vo direct3d -fps 35 -cache 512 -

if you install to different paths you need to adjust the path of course!

Thanks for the tip!

I have installed Ubuntu on my computer and got the exact same problem there (surprise?). However, this fixed it for me:

sudo apt-get install libopus0
sudo apt-get install gstreamer1.0-libav

Anything similar I can do in windows?

i’m not sure if i remember correctly;
i believe it was a libav issue
make sure to install full gstreamer and add the libav module from gstreamer (merge modules)

In case anyone else get the same problem:

I had not installed gstreamer correctly, make sure to install “complete” version to get all plugins installed.