Emlid

Community Forum

Navio2 + Reach - 2nd GPS question


(Khan) #1

Hello people, I am new here and using reach RTK GPS for the first time. For my project I am trying to recieve correction data from the RTK GPS over USB to navigate a ground robot. For the ground control station I am using APM Planner 2.0.
The setup-
I have a RPi 3 and to it I have connected a Navio 2. I have the GNSS antenna connected to the Navio 2. I have the RTK GPS that I have connected to the RPi’s USB. I have the ardurover set up for receiving the correction data from the usb by choosing TELEM2="-E /dev/ttyACMO"
Unfortunately I am still not seeing the second GPS data on mission planner.
I would appreciate any and every help.


Usb output
(Tatiana Andreeva) #3

Hi @akhan1,

Please post here the content of your /etc/default/ardurover file and the output of following commands:

  • systemctl status ardurover
  • dmesg | grep -i tty

Is the last symbol in ACM0 entered as zero?


(Khan) #4

Hi, first of all, thank you so much for getting back to me so soon. I have attached the two command outputs and also the file.
pi@navio:~ $ systemctl status ardurover
● ardurover.service - ArduPilot for Linux
Loaded: loaded (/etc/systemd/system/ardurover.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2019-05-30 21:23:28 UTC; 18h ago
Docs: https://docs.emlid.com/navio2/navio-ardupilot/installation-and-running/#autostarting-ardupilot-on-boot
Main PID: 364 (sh)
CGroup: /system.slice/ardurover.service
├─364 /bin/sh -c /usr/bin/ardurover $TELEM1 $TELEM2 $TELEM3
└─369 /usr/bin/ardurover -A udp:192.168.1.110:14550 -E /dev/ttyACM0 -C /dev/ttyAMA0

May 31 16:00:30 navio sh[364]: $PGCMD,16,0,0,0,0,06A
May 31 16:00:30 navio sh[364]: $PSRF100,0,38400,8,1,0
3C
May 31 16:00:31 navio sh[364]: $PGCMD,16,0,0,0,0,06A
May 31 16:00:31 navio sh[364]: $PSRF100,0,38400,8,1,0
3C
May 31 16:00:32 navio sh[364]: $PGCMD,16,0,0,0,0,06A
May 31 16:00:32 navio sh[364]: $PSRF100,0,38400,8,1,0
3C
May 31 16:00:33 navio sh[364]: $PGCMD,16,0,0,0,0,06A
May 31 16:00:33 navio sh[364]: $PSRF100,0,38400,8,1,0
3C
May 31 16:00:35 navio sh[364]: $PGCMD,16,0,0,0,0,06A
May 31 16:00:35 navio sh[364]: $PSRF100,0,38400,8,1,0
3C

pi@navio:~ $ dmesg | grep -i tty
[ 0.000000] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[ 0.001136] console [tty1] enabled
[ 1.157187] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
[ 37.064591] cdc_acm 1-1.3:2.2: ttyACM0: USB ACM device

File -

Default settings for ArduPilot for Linux.

The file is sourced by systemd from ardurover.service

TELEM1="-A udp:192.168.1.110:14550"
TELEM2="-E /dev/ttyACM0"

Options to pass to ArduPilot

ARDUPILOT_OPTS="$TELEM1 $TELEM2"


(Tatiana Andreeva) #5

@akhan1,

Could you please share the simple system report from Reach and hardware setup photos as well?


(Khan) #7

The simple report -

Simple system report
app version: 2.16.2-r0
'wifi_status, interface: wlan0':
- wifi_mode: wpa_supplicant
- ip: 192.168.0.101
  is_connected: true
  mac_address: 90:b6:86:09:bf:fe
  ssid: emlidltd
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
  output:
    enabled: true
    format: rtcm3
    path: tcpsvr://:9000#rtcm3
    type: tcpsvr
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1010':
      enabled: true
      frequency: '1'
    '1097':
      enabled: false
      frequency: '1'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
camera:
  duty cycle: 20
  enable: false
  period: 2
  polarity: true
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: 192.168.0.105:9001
    send position to base: 'off'
    type: tcpcli
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
    version: null
  solution:
    format: LLH
    started: true
    version: null
position output:
  output1:
    enabled: true
    format: erb
    path: ttyGS0:38400:8:n:1:off
    type: serial
  output2:
    enabled: false
    format: llh
    path: :9001
    type: tcpsvr
  output3:
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
  output4:
    enabled: true
    format: llh_ext
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: false
    glonass: true
    gps: true
    qzss: true
    sbas: false
  snr mask: '35'
  update rate: '5'

(Tatiana Andreeva) #9

@akhan1,

All configurations seem to be proper at first sight.

What was the solution status in ReachView app when you’ve tested the setup?


(Khan) #10

The reach view for the RTK GPS shows “Fix”. I do have another question @tatiana.andreeva , for this project as I am using APM Planner as goround control station and Reach RTK GPS as my 2nd GPS which is getting correction data from a base(Reach RS) how do I know for certain that APM Planner is using the RTK data and not the regular GPS that is standard with Navio 2.


(Tatiana Andreeva) #11

Hi @akhan1,

What GPS status does APM Planner show?
Is there any issue with using MP?


(Khan) #12

Hi, @tatiana.andreeva I have successfully connected the second GPS but it only connects when I run the command -
sudo ardurover -A udp:192.168.0.110:14550 -E /dev/ttyACM0
When I enable ardupilot on boot it does not see the second GPS over usb. So I disabled it and am running the command from terminal. I was wondering if there is any way I can automate this process.
To answer your second question I am using APM Planner because I am making changes to the UI and adding other features.


(Tatiana Andreeva) #13

Hi @akhan1,

First, may I ask you to run emlidtool with sudo emlidtool autopilot and post here the screenshot of it?

As for your second question, it’s possible to understand which GNSS module is used by checking gpsstatus parameter that should be shown on the main screen. The primary GPS module can’t show 4 (RTK float) and 5 (RTK fix).