NAVIO2 - RC S.BUS input not working & Not Auto-starting APM on boot (ALL FIXED)

Problem 1
So i’ve just received my NAVIO2, after configuring it to run APM I encountered some problems. I’ve been trying to connect my Frsky Taranis - Plus to the NAVIO2 through the X8R receiver. It appears that the NAVIO2 isn’t detecting the Sbus input. I have also tried several receivers one being a RMILEC R4047NB20. I would appreciate it someone would help me troubleshoot. I’m connecting to theNAVIO2 through the ethernet port using mission planner.
I have also used;
git clone https://github.com/emlid/Navio2.git
cd Navio2/C++/Examples/RCInput
make
sudo ./RCInput

and receive continuous 0 with approximately one second delay.

Problem 2 >Fixed<
after successfully installing the APM firmware onto the NAVIO2 I can successfully launch the application using the command: sudo ArduPlane -A udp:192.168.1.2:14550 -C /dev/ttyAMA0

However I have to use this command each time after rebooting the raspberry Pi. I’ve tried autostart in the APM through the code: sudo ArduCopter-quad -A udp:192.168.1.2:14550 -C /dev/ttyAMA0 > /home/pi/startup_log &
and it starts the APM firmware however after restarting the raspberry Pi the firmware does not start-up automatically. Any ideas?

Many thanks Bryce,

It looks like you’re just running the command from the CLI.

You need to add it to your /etc/rc.local file, like:

“sudo vim /etc/rc.local”

And then add the line you are talking about in there.

Hi Nathan thanks for your reply,

so 'ive ran the code and apm start up, but when i power down and then back up agen it dos’nt run

is it just ment to start running after turning on?

You need to edit the file “/etc/rc.local” and add the commands in there.

When the raspberry pi starts, it goes to that file and and runs the commands found there. That is what will start the process automatically.

Thanks Nathan,

It’s now Autostarting APM on boot.

Do you have any idea on the RC input?
ive tryed S.Bus and a PPM Encoder, so i need to add any code?

Hi Bryce,

Can you provide a picture of how everything is connected?

Hey so sorry for the delay i wasn’t home for a compel of days,

Uploading…
Uploading…

here is an image with the PWM encoder and just the S.BUS cable.

sorry i thinks this wil work

Could you please try following the debug steps that I have listed in this topic?

okay so,
i put a new OS on a Differrent SD card and didnt work so,

cat /sys/kernel/rcio/status/alive
gave me 0

cd /sys/kernel/rcio/rcin
sudo cat connected
gave me 0

any ideas?

i did this with the S.BUS and PPM

So i have fixed it :slight_smile: :slight_smile: :slight_smile: :slight_smile:

what i did wrong;

Placing the OS image into my Google drive, why this happened i have bo idea but re-downloading it and not placing it in my Google drive fixed all my problems.

I hope this helps

Thanks

Nathan_Belk & ivereninov for all the help you have given me <3

Bryce

1 Like