NAViO2 / RaspPi3 - Wifi issues

Hi All,

I was having trouble connecting so i started from scratch, new boot sd

logged in with Pi and Raspberry


sudo nano /boot/wpa_supplicant.conf

and added the text and updated wifi info


re logged in

sudo cat /boot/wpa_supplicant.conf - should probably input this into to the instructions for noobs like myself

checked info

Still no connect to the wifi?

UPDATE - Dont just check what devices are connected to your router in also make sure the setting are set to let new devices connect. i didnt know you could filter IP/MAC addresses, you can spend a week pulling your hair out thinking youve typed in codes wrong. THANKS AGAIN ALL INVOLVED.

Unplug your Ethernet cable. Unless something has changed WPA Supplicant monitors your network connections and will only allow Ethernet or WiFi. Not both at same time. If you want more tech info on ifplugd and other details behind this we can get into it. But for now don’t try to use Ethernet and WiFi at same time.


Could you please post the contents of your wpa_supplicant.conf?

Found my notes. If it helps. As @mikhail.avkhimenia has asked, likely better to see your conf file to make sure it’s right. But not sure how many man hours I wasted a few years ago when I was trying to get WiFi working on a linux box while using eth0 to admin the same box. Anyway, here are my notes on one workaround for eth and wlan at same time…

WPA supplicant, required for WiFi roaming, monitors ifplugd events and will shut down any roaming interface it is managing when eth0 is plugged into RPi.  So we just exit the script it calls during these events.  

Edit config file for wpa and add an exit to top of script:

sudo nano /etc/wpa_supplicant/action_wpa.conf

# Exiting script to enable eth0 and roaming wlan to work at same time
exit 0

Thanks for the replies i’ve only just finished work.

Coby i’ve reinstalled from scratch do i still need to do this as i’ve got no ethernet connected now?

No need for the hack I noted above unless you want to run eth and wlan at same time. Not a requirement for most.

any idea why my wifi isnt working?

Sorry, it’s hard to say. You could start by getting rid of the key management line. Just start with ssid and psk. Start with simple stuff like double-checking your ssid - it is case sensitive. Then work out. Try another network etc. Assuming you are using built in RPi WiFi? It’s not very powerful so you may have to move closer to AP. If you are using a USB dongle are you sure it’s supported in linux out of the box? I use TP Link dongles that require us to compile drivers. Just try to rule out one thing at a time.

1 Like

thank you for your time

will it have anything to do with the sd image i made bootable? i downloaded the “Emlid Raspbian Image” not the “Emlid Raspbian Beta Image with ROS and WBC support” as i have no idea what that means

i think ill try it at my dads house as it could be my router, yes i’m using onboard wifi

The one you downloaded will work just fine. The Beta is adding features you likely don’t need to worry about right now. It’s a steep learning curve. You’ll get it.

1 Like

you have to add your wifi credentials to the file: /etc/wpa_supplicant/wpa_supplicant.conf !!

instead of /boot/wpa.suplicant.conf

1 Like

Hi Panky

i opened

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

and it was the same info?

when i edit in nano and exit to save another set of options pop up along the bottom

get help/ cancel/ dos format/ mac format/ append/ prepend/ backup file << i just clicked enter as i didnt know what any of the options will do?

/[quote=“Jimmy_Hill, post:12, topic:4697”]
get help/ cancel/ dos format/ mac format/ append/ prepend/ backup file << i just clicked enter as i didnt know
enter was correct - don’t bother about the rest;

I assume your wifi credentials are correctly put in your wpa_suuplicant.conf file:
can you see your home network when typing:
sudo iwlist wlan0 scan | grep ESSID

yes i can see the network, ive rechecked the details and everything matches added - county=UK to the list too

checked iwconfig and still not connected

if i wipe my sd card again will anything need wiping on the pi?

Wi-Fi networks can be configured by editing the /boot/wpa_supplicant.conf file located on SD card. To add your network simply add the following lines to it:

^^^^^this is what it says on the instructions add it to boot

what does this command do - sudo dhclient -v wlan0

it is a manual connect to wifi in verbose mode; what is it’s output?

after changing your wpasupplicant.conf you should reboot (or “sudo ifdown wlan0” and afterwards “sudo ifup wlan0”)

if you wipe your sdcard all informations on rpi and Navio will be lost - nothing left;

thanks for your help panky

as @coby said, remove that line (“key_mgmt…”)

also check your router has enough IP adresses in range and MAC address control is off;
what router are u using?
can u see a live log on your router when rpi is trying to login?

make a hotspot with your phone and some login credentials as your router, turn off your router, try to connect your rpi!

1 Like

Well bugger me!

you was correct the router wasnt assigning an IP, i was looking on the devices list connected to check if the pi was connected not realising the other page settings turned off

sorry for wasting everyones time.

Thank you sooooooooo much!

great it works

1 Like