Emlid

Community Forum

Navio2 + PX4 + MAVROS


(Alexis Offermann) #1

Hi there,

I’m using PX4-emlid-navio2 with the RPi3 and want to let them communicate with the on-board mavros.
How can I do this ?
I have probably a trouble with the FCU adress given in the PX4 / or on the mavros node start :
For PX4 i do this :

mavlink start -d /dev/ttyAMA0 -b 921600 -m onboard -r 80000
INFO [mavlink] mode: Onboard, data rate: 80000 B/s on /dev/ttyAMA0 @ 921600B

For mavros i do this :

roslaunch mavros px4.launch

with following relevant lines in the px4.launch file :

 <arg name="fcu_url" default="/dev/ttyAMA0:921600" />
 <arg name="gcs_url" default="udp://172.26.143.43:14551@172.26.142.79:14550" />

And by the way : I tried with an external pixhawk that just worked fine with the serial communication. But not with the navio2


(Tatiana Andreeva) #2

Hi @alexis.offermann,

We officially support only ArduPilot on Navio2. We’ve never tested Navio2 with PX4, so, I’m afraid, I can’t be of much help on this.

Hope there is somebody from our users who works with PX4 and might help you to resolve the issue.


(Alexis Offermann) #3

Ok thanks !

Another question for you then,

is there any node in Ros using ardupilot that can directly command the PWM of the navio ?
I know the offboard mode that allows to use the actuator control node with the PX4, but that doesn’t exist with ardupilot from my point of view.
Any idea?

Alexis


(Tatiana Andreeva) #5

Hi @alexis.offermann,

Sorry for the delayed reply!

You can publish values to /mavros/rc/override topic with rostopic tool to control PWM outputs.


(Alexis Offermann) #7

yes i tried that, with a delay of 2seconds.
Eventually i’m trying a costum ros node based on the navio libraries that won’t have the latency.
I will try and update response ASAP.


(Tatiana Andreeva) #8

Hi @alexis.offermann,

It’d be great to see the results. :slightly_smiling_face: