Navio2 PWM problems with QuadPlane - SOLVED

I am working with a team that is building a quadplane. We are using a navio2 board, a RPi 3 and a recent version of Arudpilot SW (downloaded in September).

We have started doing integration of the Navio2 with the quad lift ESCs and electric motors and we noticed a skipping noise coming from the electric motors on a regular basis.

To enable quadplane, we set Q_ENABLE=1, SCHED_LOOP_RATE=300. Based on another forum we also tried setting Q_RC_SPEED=300.

We connected the ESC to a RC receiver and it works fine, so we believe the ESC and motors are working. Also, we loaded ArduCopter to try all 4 lift motors and these worked.

After connecting an oscilloscope to the Navio2 outputs it was found that the PWM is erratic, and occasionally has long pulses and occasionally has missing pulses. This is happening on all 8 output channels, not just the lift motor channels.

So, enabling Quadplane is causing all output channels to have erratic behavior.

After doing some debugging, I added some code to function RCOutput_Sysfs::write to only output channels 1-4 and the PWMs worked as expected. As soon as I change this function to output channels 1-5, the PWMs start acting erratically. This function is one layer above the call to Linux, so it appears ArduPlane is working correctly, and problem is with the Linux layer

Any ideas as to the problem and how to solve it?

I saw another forum entry that mentioned that channels 5-8 should not be used, does this still apply and does it apply to QuadPlane?

Found a workaround based on another post. PWM channels 5-8 do not work for auxiliary motors and Quadplane is using auxiliary motors for the quad lift motors. By reassigning channels 5-8 to 9-12 via the mission planner, the erratic PWMs are now gone.

One downside of this approach is that on the status page in MP planner, channels 9-12 are not updated and indicate 0.

Would be nice if the channel 5-8 problem could be fixed in Navio2.

Yep agreed this really needs to be sorted. There’s something seriously at fault with the RC_out system I’m not getting relays to work either, on any channel. I question why this issue has been put on the back burner so that they focus on rolling out WIFI broadcast.

@strobelite1 @Wildtypitch sorry for the inconvenience with the channels. We are working on this too, but it may take some time to be released because it requires quite a big rework of the RC IO firmware.

How do you reassign channels 5 to 8 to 9 to 12 in Mission Planner?