Navio2 Pi 2B 20160212 Img not working


I tested my new Navio2 Board and it connects fine to the mission planner when i use the emlid-raspberrypi2-raspbian-navio2-20160203,ing but fater upgrading to the more recent one emlid-raspberrypi2-raspbian-navio2-20160212.img it no longer wanted to connect to mission planner.

Both tests were done with out doing any other configurations or changes to the pi other then installing the apm.deb.

The c++ examples foe LED,PPM,Servo on both imgs do now work and give a Failed to write device(-1): Input/output error
the LED does how ever change “flash” when running the ArduCopter-quad command

I have not tried building the APM from source on the new Img i will try that now.

If any one ahs any input on the C++ eample issue it would be great as i have dual application fot the board one useing APM and the other using standalone code.


Are you trying to run examples at the same time with APM?


Thanks for speedy reply

No i am not.

All other examples work fine, it just seems the be the ADC,Led,Servo,PPM-decoder, i did also install the libpigpio as per instructions before compiling the PPM-decoder.


Navio2 does not use pigpio, so there is no need to install. Have you by any chance performed any update/upgrade commands?

no i simply load img on SD card login via ssh

git clone GitHub - emlid/Navio: Collection of drivers and examples for Navio shield for Raspberry Pi.
cd Navio/C++/Examples/
i got he following error and therefore assumed i needed the libpigpio

g++ -I …/… -I -L PPM.cpp …/…/Navio/PCA9685.cpp …/…/Navio/I2Cdev.cpp …/…/Navio/gpio.cpp -o PPM -lrt -lpthread -lpigpio
PPM.cpp:15:20: fatal error: pigpio.h: No such file or directory

the servo example how ever also gives the following error when i run
Failed to write reg: Input/output error
Failed to write device(-1): Input/output error


Should be this one GitHub - emlid/Navio2: C++ and Python sensor examples for developers . Sorry about the error in the docs, it will be fixed.

1 Like


Works great now.

Should of noticed /thought of that.

I still how ever seem to have an issue connecting the APM to the MissionPlanner on the new image. Is it also possible that i might have also downloaded the incorrect ARM build, the one i have was from .

As i mentioned on the older image this .deb works fine and connects 1st time.