Navio2 No INS backends available


after about one month since i bought my navio2, all that time i was slowly progressing and getting to know about how to setup navio2. I managed to set telemetry transfer and video transfer as well through 3g network.
However, yesterday i finally put my navio2 onto my quadcopter and started doing a compass calibration according to your docs using onboard calibration process of mission planner. I realised that compass1 was not getting updated with green values. Then i tried to power off and on again navio and i realised that suddenly APM couldnt even be autostarted but could neither be manually started using the command sudo ArduCopter-quad -A as it was returning NO INS backends available. So i went to sleep

Today, I powered again my quadcopter and the APM autostarted normally as expected. But again when i tried to make the compass calibration through mission planner compass1 would still not get updated with green values but it was showing red values. THen, again when i rebooted navio i couldnt autostart again APM. So I decided to format my sdcard and install from scratch raspbian image (using the latest image 20160718) and APM according to your docs. After a fresh install again i couldnt start APM because I was getting the same message NO INS backends available

SO i decided to run the navio2 examples that you offer. THe result of running these examples is shown in the attached image. I am confused and i dont know whats going on. Why APM cannot get started and why does compass calibration never updated compass1 values??? For a whole month I never had problems starting APM and never received this message NO INS backends available . Why does it suddenly start to appear ??
THe above issues occur no matter if i supply power to navio through microusb or through the power module.

Please advise
Thank you


It looks like there is no electrical contact between Raspberry PI and Navio2, please check that board is screwed tightly and spacer connector is firmly connected.

Dear Igor,

i really doubt that there is no electrical contact between rpi2 and navio2 because my boards are inside the 3d-printed navio2 case and the case is screwed normally and tight. However I will check again later although i dont think there is something wrong.

are there any other suspisions about what might be wrong ?

thank you

What this error says is that ArduPilot (and example) is not able to establish connection to MPU9250 sensor. Possible reasons could be: bad connection between boards, dead sensor, dead SPI bus on RPi. Try to run other examples, do they work?


i will let you know later

So, finally it seems that the problem was bad connection between boards as you said… Quite strange as my boards were screwed normally between a 3d printed navio case… SO when i applied even a very very small pressure in any direction on the case, the compass would be recognized .

I suspect that my navio case is slightly distorted that causes tha boards to be stressed a little bit causing this interminnent contact problems… I have now removed the case and everything is OK

THank you