Navio2 + NEO-6M Compass "Bad BARO Health"

Arducopter V4.03
MissionPlanner 1.3.70

I am trying to connect the NEO-6M GPS/Compass specifically the compass to the I2C port but it seems there is a conflict with the barometer, which I assume is also using the I2C.

Does anyone know how to get them working in harmony?

Hi Lee,

Could you post the output of sudo i2cdetect -y 1 when it’s connected?

With the NEO-6 connected (I2C) this doesn’t finish and is really slow. If I disconnect it’s super fast and 70:7 = 77, otherwise it slowly gets about half way and freezes.

  1. Have you double checked that your wiring is the same as per the Navio2 documents?

  2. Do you know if this GPS module works with another light controller?

  3. Did you follow the instructions on how to setup your secondary gps on the serial port

  1. Yes
  2. I’ve not tried it with anything else yet.
  3. I’m not using the GPS (TX/RX) just using the compass part (I2C)

Hi Lee,

Sorry it took so long to get back to you!

May I ask you if you have tried using the NEO-6M GPS/Compass while connecting the GPS itself just to test that it would work?

Have you had a chance to check out these Ardupilot’s guides on how to work with the U-blox GPS/Compass and how to calibrate the compass?

Could you please share if during your tests the barometer on Navio2 was covered with foam as suggested in this guide?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.