Emlid

Community Forum

Navio2 , Mission planner, AP lidar A2


(Bryant Jackson) #1

Before creating a new thread please refer to the documentation for Navio2 and Navio+.

In case you are creating a thread about an issue it is necessary to provide following information to get help:

I am using Ardurover 3.4.2 , i am trying to connect a RP Lidar A2 through the UART on the NAVIO2 board. My issue is that i do not know how to access the UART port through mission planner. Most of the boards/documentation i have read tell me to use the SERIAL_4 but i am not getting any data. Sorry if i did not provide enough information. I am very new to robotics and doing this for a school project. Thank you for any help on the subject


(Sebastian) #2

You should run ardurover 3.5 to fully use a 360° lidar.
Serial ports are assigned to the ardurover executable via startup options.
You could just use option -C for serial1 which is normally used for a telemetry radio and change the parameters in ardurover to suit the rplidar.


(Bryant Jackson) #3

Thank you for your help, I have tried to upgrade the firmware to 3.5 but I cannot get the navio to show up on any comport I can only connect wirelessly through mavlink, I am trying to plug the pi into the computer with a micro usb is this the correct way to connect to update to 3.5?


(Tatiana Andreeva) #5

Hi @bryant.jackson,

You can upgrade the firmware using this command:

sudo apt-get update && sudo apt-get dist-upgrade

It’s also possible to reflash the SD card with the latest raspbian image using Etcher.


(Bryant Jackson) #6

Thank you so much for your help !


(Matthew Cunningham) #8

I have done the sudo apt-get update && sudo apt-get dist-upgrade but cannot get ardurover 3.5 to show up at all, running navio2 with rpi B3. Need 3.5 for wheel encoder support. Should I just do a fresh install?


(Tatiana Andreeva) #10

Hi @Matthew_Cunningham,

Yes, please try to reflash RPi using the link I shared above.


(Matthew Cunningham) #11

@tatiana.andreeva

No luck downloading newest raspbian in the link provided only rover version available to me is rover 3.4. Any other ideas why rover 3.5 is not showing up? 3.4 does not include the proper wheel encoder parameters needed.

edit: that is unless you are calling ardusub 3.5 ardurover 3.5? which is ardurover now, there is no need to have ardusub in there unless you have a reason to as ardurover is now arduboat and ardusub, if that makes sense. I will try this ardusub 3.5 which I’m inclined to think is actually ardurover 3.5. we shall see


(Tatiana Andreeva) #12

Hi @Matthew_Cunningham,

Sorry, I somehow missed the fact you require ArduRover 3.5.
Our current image supports ArduRover 3.4.2 only. However, you can build the ArduRover 3.5 binary using this guide from our docs.


(Matthew Cunningham) #13

@tatiana.andreeva
then what is ardusub 3.5? As they don’t even have that firmware anymore as its rolled into the ardurover now and you just select a frame class either rover or boat


(Sebastian) #14

That is not the case. Ardusub is still a seperate firmware. Ardurover is for surface vehicles only.
You will not be able to use wheel encoders with the Navio2, because the RC I/O chip does not support any input on the servo rail.
Wheel encoders were already supported in 3.42 for pixhawk based flightcontrollers.


(Matthew Cunningham) #15

Yes wheel encoders are supported in 3.42 but they are not the correct settings for specific wheel encoders. So this is a mook point as its not even supported. Ardusub is no longer an ardupilot project and has not been included for sometime. Although it does exist its not ardusub by the ardupilot project. So where did this ardusub come from?