Navio2 MavLink FrSky SPort telemetry using teensy need reboot

Hello.

I’ve tried to search the forums of a similar problem that i face, but i could not find any.

Anyway, i’ve soldered together a Teensy 3.2 according to this repo. Creds to all the great minds out there for creating it! Works great! Just a few snags getting status msgs.

The problem is that the Teensy board doesn’t seem to recive any data from the Navio2 until i restart the navio2. I’ve mesured the current, so it is not an “powering issue”. After i restart Navio2 from MissonPlanner (ctrl+F) or using SSH with the command “sudo systemctl stop arducopter” and “sudo systemctl start arducopter” the LED on the Teensy starts blinking and i get telemetry at my transmitter.

I do not know how i should get the teensy to start reciving data the first time i start navio2, or how to proceed to debug it?

SETUP information below:

The Teensy is connected to the S.port on the X8R reciver (which again is powered from BEC through the servo rail on the navio2). From the Teensy to to Navio2 i have a tx, rx and gnd connected to UART using one of the original UART cables that came along with my Navio2. So i think the Teensy have dedicated use of the UART?

I have enabled the “#define AUTO_MAV_STREAM_CFG” in the “MavLink_FrSkySPort.ino”, but it seems that it don’t work? I tried to reset the parameters on Navio2 to see if it changed it back, but nothing happened. I then configured the SRn_1 and SERIAL1_ parameters manually. I get telemetry, but only after i restart the Navio2 as described abow.

Im on arducopter 3.4.6, from the official emlid image. MissionPlanner v3.4.6 (5221448a).

pi@navio:~ $ emlidtool
emlidtool version: 0.8.8
Vendor: Emlid Limited
Product: Navio 2
Issue: Emlid 2017-03-23 5e28de2c424cadfb61a62b88e9c0af98a6d25545
Kernel: 4.4.36-a7765e7-emlid-v7+

Telem2 is connected to the teensy board and telem3 is connected to the 2nd GPS using a CP210x board.

TELEM1="-A udp:xxx.xxx.xx.xxx:xxxxx"
TELEM2="-C /dev/ttyAMA0"
TELEM3="-E /dev/ttyUSB0"

ARDUPILOT_OPTS="$TELEM1 $TELEM2 $TELEM3"

Any ideas is well appreciated, thanks!

Topic can be deleted, the issue is resolved.

I just poked into raspi-config interface options and disabled login shell over serial and enabled serial port hardware.

Dont know what was wrong, but it works like a charm now!