Navio2 + FS-İA10B + Flysky Nirvana

i’m so new about drones and i would like to learn everything about this. and when i search a little bit, i learnt that navio2 is the best for me. but aproxieametly 2 months i’m trying to do my drone but unfortunatelly it’s not flying. i’dont know where is my fault.
i choose this parts;
Raspberry pi 4 2GB Ram - 32 GB MicroSd
Navio2 Set and GNSS antenna
Matek PDB
SunnySky A2212 motors
BLHeli 32 1200Dshot ESC
FlySky FS-İA10B Receiver
FlySky Nirvana 14 CH Radio
Fs-X8B - Receiver(this came with the radio but its connectors are different so i tried the other receiver. these days again i’m tring this receiver but i still couldn’t bind with my radio. on the other hand i can bind my radio with FS-İA10B. wheni use fs-ia10b, i’m trying to take a signal from navio2 and i can take signal. and when i connnect the motors to the receiver it is also working but when i try to connect receiver with navio2, i cannot control the motors. and when i ty to connect misson planner, i can connect but i cannot load or test any motors. i don’t know where the problem is. but sadly other thing is radio is a little bit strong so i cannot adjust it.)

Hi @mesutarslan983,

Could you clarify whether you completed radio and ESCs calibration?

Also, may I ask you to share your hardware setup photos?

thanx for your answer. of course i will send you my hardware.

i use I2C port just for power to servo Railway. :slight_smile: i mean i took Vcc and Ground pin and i connect this pins to the railway

FS-İA10B is my receiver and others are alternatives. other 2 is came from my Radio Flysky Nirvana. especially if i Success to bind fs-x8b i will use this one. right now i bind with fs-ia10b. but i will try for other receiver binding

finally i bind other receiver to the navio2. i mean right now, a receiver which came with radio is my receiver. and i have just one problem. if i controll the motor i thing everthing will be ok. which parameters do i need for this operation and without telemetry module via wi-fi how can i load and upgrade my system with the parameters. because i’m conneccting the mission planner or GCS but i cannot change or adjust the parameters. always i took message for fail.

when i try to test my motor from mission plannner. i got a fail message like, mission planner cannot reach the auto pilot.

i solved the problem :slight_smile: but also i need help. from this photo when i choose PWM and when i connect motors to my receivers (doesn’t matter which one but especially fs-ia10b) i can controll the motors. but navio2 doesn’t take signals. becaause when i make the test of RCInput i don’t have any signal. but from this menu if i choose ppm and when i make test RCInput, at this time i can see the signals and numbers at my screen. but on the other hand at the ssame way with ppm when i connect the motors to the receivers i cannot control the motors. also when i attach the servo railway i have never take any move. by this way i need to describe my pwmm signals to the navio2. and how can i do this.

summer if pwm enable from radio, i can control motor when they connect the receiver. but i cannot see the signals on the navio2

if ppm enable from radio i cannot control motors anyway. but i can take see the signals from navio.

And when you use ibus servo out, what is the result?

with ibus idon’t have any answer. at least i tried fs-x8b (receiver which came with radio) sbus pin and from radio pwm-i or ppm-i out. i can control motors from receiver one by one but no signal from navio. if i choose pwm-s or ppm-s i have signal from navio2 but i cannot control motors.

if i try FS-İA10B i-Bus ppm-i and ppm-s i got signals from navio2 but motors not run.
i’m still trying.

on the otherhand i got an interesting problem. when i connct the mission planner or GCS from LAN cable with UDP i can take the parameters but when i try to calibrate i cannot do this and when i try to test motors i got a message and it is writing that cannot reach the autopilot.

i solved all problems. thanx for everything. my main problem was calibbrating the ESC. finally i did it. but still one of my motor doesn’t work. if i will solve the problem i will write it. without navio2, when i try, it is working. when autopilot run 3 motors are runing.

step by step i will solve and do this. :slight_smile: right now 4 engines are ok. system is ok. anddd (another but),
but i got problem to connect the mission planner or QCS. i mean that i can connect but when i try to calibratte my system. i cannot do this. for each time i took a message which writes ‘fail’ annd i’m trying to connect via wifi. for the next days i will try with telemetry. after that i will write again.

And now my question. but just question. İ would like to attach my fpv camera to navio2. from the servo rails. for example 5. 6. or another one. ca i do this. can i attach my fpv camera to the navio2?

thank you so much. :slight_smile:

Hi Mesut,

Thanks for keeping me updated and sharing the solutions!

Could you please clarify what exactly you try to calibrate?

ArduPilot supports such cameras. However, I assume you might need additional hardware to set up an FVP system on your drone. Please check this page from ArduPilot docs. It describes a typical setup scheme.

i tried the 3dr telemetr sistem and i could calibrate. :slight_smile:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.