Emlid

Community Forum

Navio2 Flight Stabalization Issue


#1

Testing a Navio2 in manual mode. The drone could take off (check the video) but was oscillating a lot. Seems like a software issue. Please suggest some steps to try!

https://drive.google.com/file/d/1j55LDx1hHuKE5-GZgC_iWrGPnmmNe6bP/view?usp=sharingVideo Demo


#2

That close to the ground there will some propwash under it, making it hard to stabillize it.
Do yo have a closer picture of your setup?
Is the mandatory step in the setup for Ardupilot done?
When you say manual, do you mean stabillized mode? Stabillized mode in Ardupilot is the recommended mode for first flight.


#3

Hi TB_RTK,
Thanks for the prompt reply. I have done all the necessary sensor calibrations (accelerometer, compass, RC) with GCS and the ESC. In this test, I was controlling the throttle with a radio controller. Not sure how stabillized mode can be set up? I also attached the photos of my setup. Thank u!


#4

Check if Stabillized mode is active and no other channel interfer with the output.
Assigne a switch for different modes. I have stabillized, alt hold and auto as default switch setup on mine.

It seems somewhat overpowered or over propped…What is the take of weight and thrust ratio on this thing?

Link to mode setup
http://ardupilot.org/copter/docs/common-rc-transmitter-flight-mode-configuration.html


#5

Ok, I will try assigning different modes.

And yes, the propellers are likely to be over sized. According to this source, the size of the propellers is “determined by taking the smallest of the length or width of your drone frame, and dividing by 2”

Source: https://www.droneomega.com/quadcopter-propeller/


#6

There is like zillion guide on how to on the prop/esc/motor/frame setup. And they are probably all good.
One i like to remember that i read somewhere, is 2x the takeoff weight and add 20%.
If you drone is 1kg, your total thrust would be 2,2kg of thrust. That should make you hover at 50% throttle stick. Divide that by the number of motors and you have the thrust pr motor/prop and combo it needs to be.
But in your setup it might be all fine. Try first setting up the propper mode selection and start of with stabillized mode.
http://ardupilot.org/copter/docs/ac_tipsfornewpilots.html