Navio2 ESC Drive Problem

Hi, I am having trouble with the final stages of my quadcopter build using a Navio2 controller. My setup is:

RPI4, 1G memory
Navio2, purchased about 1 year ago from RobotShop
Luminear 36A BLHeli_32 ESCs

QGroundControl v4.0.6
kernel 4.19.83-emlid-v7l+
ArduCopter 3.6
(no apt-get update)

It all checks out and arms with QGroundControl. Vehicle type is quadcopter, however, only two motors spin. The ESCs that work are driven from pins 2 and 4.

I have programmed an Arduino as an ESC tester to ramp the motor up and down and all four motor systems are good, tested at the plug that goes in the Navio2.

In QGroundControl with Motors Setup selected, enabled, and moving the All slider up, it arms and moves all motor sliders up, but only two motors spin. It does show 4 motors.

Thinking a bad reciever SBUS output, I tried changing to PPM and got the same results.

I tried to set up a USB oscilloscope to look at the signals but it won’t work (either).

Anyone have any idea why pins 1 and 3 seem to have no output?
Could the multi-protocol ESCs be getting confused?
Would any of the demo programs be of use?


Hi @Brian2,

Sorry for the delay.

Have you tried to perform a motor test in the mission planner? That guide could be helpful.

Can I ask you to connect servos directly to the receiver’s channels and check whether they react on commands from the RC transmitter or not?

Hi Artem,

Thanks for the reply, but I think my Quad is haunted by ghosts.

I got 3 motors working by re-configuring to Hexcopter, moving the ESC connectors to higher numbers on the Navio2, running the 3 motors that worked, then moving the connectors back and re-configuring to Quad. No idea why.

Per your good suggestion, I then used an older separate output receiver (no sbus) to connect directly to the ESCs and all motors worked with the sticks on the transmitter, BUT I had to hold the sticks at their lowest extreme for a few seconds before the ESCs would respond. Arm sequence for the ESCs?

ESCs back to the Navio2, using QGroundControl/Vehicle Setup/Motors, three motors worked correctly, one did not seem to respond to low throttle levels. It also did not respond correctly to the Radio throttle.

Seems like it could be the ESC so I ordered a new one. For testing I also ordered a different SBUS receiver, and I have a spare motor so I should be able to test more early next week.


Hi Brian,

Have you had a chance to test the news ESCs and SBUS receiver?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.