Emlid

Community Forum

Navio2 error issue!


(MJC) #1

Hello all,
I am currently new at building my own drone. I am having an issue with my Navio2. I have used the command sudo nano /etc/default/arducopter to set my TELEM 1 to my IP address of my GCS. I then use the command sudo arducopter -A udp:“IP address”:14550. When I use this command, I get the following error:
Could not detect RPi version, defaulting to 2/3
MS5611 found on bus 1 address 0x77
PANIC: AP_Baro::read unsuccessful for more than 500ms in AP_Baro::calibrate [2]

*** Error in `arducopter’: double free or corruption (out): 0x0202ce80 ***
Aborted
Because of this, I can not connect to APM Planner 2 and can not calibrate the Navio2. Does anyone know why I am getting this error? FYI, I am using arducopter 3.5, and both my ardupilot and RCIO are up to date.


(Marc Lebret) #2

Hello,

After setting your TELEM1 parameter and completion of emlidtool ardupilot process, when you restart your Navio2, arducopter is launched.

No need to “relaunch” it by sending the command “sudo arducopter…” Doing so you confuse your Navio because resources are already busy.

I tryed your process with mine and it is not happy.

Marc


(MJC) #3

So then how do I get the Navio2 to connect to mission planner? When I boot the Navio2, arducopter is set to launch on boot but without typing in the command

Sudo arducopter -A udp:“IP address”:14550

Am I missing something?


(Marc Lebret) #4

If you had followed the 3 steps after login in your navio2 from terminal:

STEP 1:
Choose your vehicle and ArduPilot version using emlidtool
(Please, read carefully all options and select appropriate one for either Navio 2 or Navio+)

  • sudo emlidtool ardupilot

STEP 2:
Set your GCS IP

  • sudo nano /etc/default/arducopter
  • sudo nano /etc/default/arduplane
  • sudo nano /etc/default/ardurover
    STEP 3:
    Reload configuration by issuing these commands
  • sudo systemctl daemon-reload

Launch, and enable on boot

  • sudo emlidtool ardupilot

You can verify that arducopter is running after a reboot (sudo reboot) and logging again to Navio.

When done,

Send the command: sudo emlidtool ardupilot

You will have this screen:

So, if you open APM planner, you should be able to connect via UDP.

(Remark: connection is automatic with Mission Planner or QGroundControl if UDP IP address of your computer is correct).

Marc


(MJC) #5

I will definitely try this. I am currently doing academic undergraduate research. My first project is to get the Navio2 up and running, so we can use it for other projects. I don’t have a strong background with computers.

I do have another question for you since you have been so attentive with your responses. When I am congested to mission planner and I go to callibrate the compass after the calibration is complete, mission planner asks me to reboot the Navio2. When I reboot the Navio2, I get a undervoltage error and the Navio2 does not boot properly. When I unplug the Navio2 and switch to a different wall outlet, this error goes away and I try to recalibrate the compass to only have the same thing happen. Do you know why this occurs? Is it because of my connection issue?


(Marc Lebret) #6

?? You really need a strong power outlet. When doing setups on my navio2, I use an external phone power bank able to deliver 3A.

If you still have problems with that calibration, before rebooting, note the calibration values. You can enter them manually later in the parameters list. Do not mix compass values, new parameters should be close of the previous ones (range and ±).

Marc


(Tatiana Andreeva) #8

Hi @mjc1521,

Have you managed to run the Ardupilot on Navio2?


(MJC) #9

Yes. I have managed to successfully connect to mission planner and run ardupilot. However, I still have some questions. Does the compass need to be calibrated before every flight? When I calibrated the compass and rebooted the Navio2, I could successfully arm and fly the Navio2. When the Navio2 was unplugged and plugged back in to the battery, I would get a blinking yellow led meaning the pre-arm checks failed. When I recalibrated the compass however, it would rearm no problem. My second question is why would I still be getting an undervoltage error after I calibrate the compass? I was originally told to check my wall to USB adapter to make sure enough current was being pulled. I changed my adapter to one that is pulling 3 amps. When I calibrated the compass as I said early, I could successfully arm the Navio2, however I was getting this undervoltage error. So I tried again this time plugged into a Lipo battery and the same thing happened. It does not seem to be messing with the Navio2 during our test flights, but I think that this may be why we need to calibrate the compass each time. What do you guys think?


(Tatiana Andreeva) #10

Hi @mjc1521,

Compass is very sensitive to all the hardware on a drone. So sometimes you need to calibrate it again. However, it hardly can be caused by rebooting.

Usually, in order to avoid the EMI, it’s better to use an external compass.

For the internal compass, please try CompassMot calibration. It should help with decreasing interference from hardware.

May I also ask you to share your hardware setup photos?

What’s the power module you use? Could you please post here your power supply scheme?


(MJC) #11

Ok, the compass is now working better. I no longer have to callibrate it before every flight. As for the undervoltage error, the problem was a loose wire on the power module. We have fixed the wire and are no longer getting the undervoltage error. I now have questions about setting up a pitot tube and data logging, but I will start a new topic for that since we have solved my initial setup problems. Thank you for all the help.


(system) closed #13

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.