Navio2 drone keeps crashing into my neighbor's house

Vendor: Emlid Limited
Product: Navio 2
Issue: Emlid 2019-11-28 55eba2e2a9cc1e7f37b6bad8342c500a46c5452c
Kernel: 4.19.83-emlid-v7+
RCIO firmware: 0xb9064332
Arducopter-3.6

The drone goes from flying ok in AltHold or Loiter mode, to loosing complete control and crashing into my neighbor’s house. At this point I am actually afraid to flight the thing in my neighborhood.

I have upload the latest log, that for some reason I cannot upload into QGC so I can review it. I have attached pictures of the build, although I will have to rebuild since the last crash broke the frame.

Thanks in advanced for the help!

00000017.BIN (340 KB)

Did you ever fly well “without” the camera installed. Your camera installation is spoofing the GPS.

With the default parameters, you could have around 12 or more satellites at the start of the flight (GPS+GLONASS).

During this flight you never were in GPS mode (Loiter or RTL).

Mark, Thank for your reply… I have the cable of the camera install, but I have not connected a camera to the end of if as of yet. I had problems with crashes ever since I did the build , but this is the first time that I reach out to the community. At first I figure I needed to remove the vibrations, so I added the anti-vibration mount and that seem to work, although no successful RTL (camera cable, no camera or camera capture). I forgot to mention that is was cloudy and with a slight wind, conditions that I wanted to test.

I have some questions…

You mentioned that with the default settings I should be able to get around 12 satellites, is there a way that I can get even more if I change some settings?

How can reduce the interference from the camera cable?

What software did you use to extract the data?

Finally I have attached logs from previous test flights, where things did not go crazy, same set up as my last flight. But it was sunny and no wind.

Thank you in advance.
-Rolando00000009.BIN (1.5 MB) 00000012.BIN (1.1 MB)

I use a web page https://plot.dron.ee

Change nothing, wait longer, one or more minutes before arming.

GPS Sat number is fine with flight 9 and 12.

Hi Rolando,

in your first listed BIN file it appears you had “Alt Hold” on all the time.
Not a good idea to take off and try to fly in that mode. Should be in Stabilize.

Regarding shielding: It is well known that Rpi camera and cable creates RF interference. So both the cable and rear and sides of camera should be shielded. The cheapest option is to wrap those in alloy foil (most households use it in the kitchen) . Another option is to use copper tape.

The camera will only work once activated in the Rpi config settings. I think from memory you have to enter “sudo raspi-config” once you’ve SSH into Rpi.
There are some instructions out there explaining how you also can take some test photos to check setup. Here is one example:

Hope this of some help.