Navio2 Current issue

In case you are creating a thread about an issue it is necessary to provide following information to get help:

  1. Image and ArduPilot version.
    Image from docs: link. ArduPilot Version: arducopter 4.0. Raspberry Pi 4B.
  2. Detailed problem description. How does expected behavior differ from the observed one?
    I have got a negative current on disarming state of copter. On arming state current changes from -2A to -1.9A, if throttle are increased. I think, that current should be near 0A if copter is disarmed and throttle is zero (correct me, if I mistake). And increase to 10A, if throttle is max.
  3. Your step by step actions.
    I connected navio using power module for navio2. I executed all stuff from ROS docs page. Then I check current in Mission Planner (it was installed from this link), I see that current is negative (-2A).
  4. Screenshot with the error.
    Battery monitor; params list
  5. If using any additional hardware please provide exact make and model.
    Early I used another power module and had an same error. I thought that power module was broken. But with emlid power module I have got the same. What I’m doing wrong? Thanks for help.

Hi Sergey,

Navio2 and power module don’t transmit the battery state to Mission Planner. As far as I know, ground control stations usually try to predict the battery monitor parameters based on the battery characteristics. That’s why I can hardly explain why you’re getting negative current values.

However, you can try to recalibrate this as described in Ardupilot docs.