Navio2 - Building APM from sources

Since I’m still having issues with motors 5 & 6 calibrating and arming with the Navio2, I thought that I’d try building APM from sources on the RPi2. Following the documentation, when I enter “make navio2-hexa” I get a response of “make: *** No rule to make target ‘navio2-hexa’. Stop.”

For the hell of it, I tried “navio2-quad” with the same results. Finally I tried “make navio-hexa”, and that seemed to begin the compiling process… but I have a Navio2, so what should I do? The root problem here is that motors 5 & 6 are not calibrating and arming, so I thought that compiling from scratch would help, but I only ended up with another issue.

Is anybody running the Navio2 on a hexacopter? If so, what worked/didn’t work for you?

Best regards

Joseph, we are catching up with APM support and something might not be in the right place yet. Sorry about the issues.

We will have a check on hexa issue and I will write you back.

Right on, I totally appreciate your efforts! Can hardly wait for the first flight!

Any word yet as to getting the hexa working?

Best regards


If you don’t need to modify the source, you’d be perfectly fine launching the packaged version, i.e. ArduCopter-hexa.


Sorry, I haven’t noticed your other post.I can confirm the issue. There was a bug. So thank you for reporting! The package will be updated shortly.
The source code is being worked on to be disclosed.


The new package has been released. In this version the issue that’d been described above, should be gone.


Right on! I’ll give the new package a try later today after work. Hopefully I’ll be able to take my first test flight tomorrow morning if everything else goes well :smile:

Best regards