NAVIO2 and Mission Planner Getting Params does not work

I have a freshly loaded PI3 and Navio2 system set up, using FrSky Radio, and talking to my GCS via UDP.

Communication is established, and telemetry is passing (as is the radio channels) however the Get Params 1 Dialog never gets the information needed and I do not have the ability to change any parameters (presumably because they have never loaded.)

Flight Data is showing up, good GPS signal, and RC channels react in GCS as expected.

Little Stuck as to what to try next. Any assistance would be appreciated.

UPDATE I have now run it with APM Planner, and it is reporting the following.

No Parameter names from param manager. This would be the problem, again any assistance would be appreciated.

Final Update Issue resolved due to PC having both a wifi and network connection (read last post). Thanks Marc for all your help


Some data is transferring, there is still some hope.

Please can you confirm PC system (Windows, Mac, Linux) and Wifi or Telemetry-Radio link?

At home I use a W10 PC (wifi) and at the field I have an Android phone with QGroundControl. No problem with both QGroundControl or Mission Planner on the PC, but telemetry radio link could be short of expectation on the field.

You can also share screen copies.


hi mlebret

Windows 7 PC (Laptop), connection is via wifi and UDP and they are about 5 feet apart, no packet loss occurring (I checked).

Mission Planner version is 1.3.62

Raspberry Pi was updated before enabling navio (which was also updated).

Let me know if there is more information I can provide.

So you should have arducopter 3.5.7 (after

sudo apt-get update && sudo apt-get dist-upgrade


Can you post a copy of your Mission planner screen, with the message info:

I have arducopter 3.6.5 but it is not relevant for your problem.

You can also try to install a fresh copy of Mission planner.


HI Marc

I am using arduplane (fixed wing)

Copy of Mission planner was loaded yesterday, so it is as fresh as I can get it.



And the Pi Setup as follows


I also re-ran update / upgrade on the Pi so it is completely up to date. No change in issue with No Parameters being passed.

Is there a switch on the configuration that I should have enabled for the UDP connection that might be impacting on it sending parameters?


I had a try with a spare Navio2 card at home. I did ArduPlane configuration (ArduPlane 3.9 and 3.8). Both are OK with parameter list download and display.

The only difference is Mission planner version, I had a beta version installed, latest beta is also OK.

I also try QGroundControl v3.4.4 and param list is OK. Also fine with QGroundControl development version.

?? I don’t think so.

If you have a spare SDcard, you can try to reload a fresh Emlid Navio2 image and redo all update upgrade process. On my side, I will do an img of my card and share it on some dropbox.

You can also check your firewall settings.


HI Marc,

Have tried APM Planner with the same issue, So suspect it is something in the configuration of the Pi and Navio2 board. WIll try a fresh image and setup.

Windows Firewall disabled made no difference.

Let you know how I get on. and thanks again for your assistance.


Update New fresh install on Pi has made no difference. My Navio2 is a couple of years old, (purchased in 2017 - I think) but it reports all ‘firmware’ is up to date. Having read through a number of post realise that it doesnt have firmware as such, but is would that be something is impacting on Param transmission?

For those that are interested, this was causes by having both a wifi and network connection running for the PC. I was using the wifi connection IP address for the UDP connection in the configuration for arduplane, and for some reason this was blocking the parameters being transmitted.

Switching to just a network connection solved the issue for me.



This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.