Navio+ startup servo output

So when starting up the Raspberry Pi with the Navio+, the pwm outputs seem to be fixed at a certain value until APM finishes starting up. On some control surfaces, this is causing issues because its causing the servo to go farther than it usually would in normal operation.

Is this normal, or do I have a problem I need to chase down?
Is it possible to change the pwm values on startup to something else?


Hi Nate,

I guess you are running ArduPlane? Has radio been calibrated? Can you describe in more details what is happening?

Arduplane, currently on the 3.5 release. Everything is calibrated (it flies great once it is up and running).

Here a rundown of how the boot sequence goes:

  1. Apply power to Navio and RPi with power module, servo rail and receiver are powered separately (regulators on this Navio have been removed as per this post.
  2. Instantly, LED on Navio turns white, all servos move to and hold at an extreme position.
  3. ~15 seconds later, channels 1-4 become controllable, all others stay at extreme positions.
  4. ~15 after that, elevator wiggles a bit, all channels become controllable.

I’m not in the lab at the moment, so that account might not be 100% accurate. I can take a video and get some oscilloscope readings later today once I get in if you like.

Thanks Nate! If you could make a video it would be super. We will have a look if this can be fixed in software or this is a limitation of using PCA9685 PWM generator and it can only be solved on Navio2.

1 Like

Hi Igor,

I’ve done some more investigating, and I’ve been unable to reproduce this outside of our test platform plane. The test platform is using some rather old Hitec digital servos, I’m guessing that the extreme position behavior is just what the Hitecs do when they have power and no PWM input.

I’m planning to put the system back in the test platform by this weekend. I can take some video then if you still want it, but I’m considering this problem solved for now.

Thanks for the help,