Navio+ & GPS

Hi There,

This is my first post. I have installed everything on my NAVIO+ board with the Pi. I can connect to my laptop using UDP and can see the NAVIO+ in mission planner. However I can’t get GPS fix. I have followed all advise on the forums, checking antenna, changing parameter types but still no luck. Seems like a lot of people have issues with GPS. Any good advice?


Hi! Please provide more details about your setup. Photos of your setup, where did you test it, can you connect to the GPS in U-center?

Hi, I tried again last night and it appears that a 3D fix was obtained. When I first installed APM (an early version) I could get a fix indoors every time. I recently updated to the latest release and could not get a fix. Moving the NAVIO+ outside and letting it sit there for 10 minutes I finally got a fix. Not sure why the sensitivity has been reduced with the latest APM release?

I’m now getting compass errors. Can you explain which option in MP I should use to calibrate the compass?


Hi! GPS sensitivity has not been reduced. You have a different satellite visibility every time and sometimes you may get a few signals through the window, but sometimes not. GPS should never be tested indoors. Testing indoors is one of the main reasons of “issues” with the GPS. It does not work like a GPS in a smartphone, it needs much better signal reception.

For calibration in MP refer to this guide.