Navio+ - Configuring GPD module for Openplotter

I recived my Navio+ board today, connected it to my Raspberry Pi 2 model B and booted from a OpenPlotter RPI v0.6.0 beta3 image : Link to download

The sensors seems to be identified correct out of the box but I’m struggling to get NMEA data from the onboard u-blox m8n module. Openplotter supports GPSD and normally all you will have to do if using a USB gps is to enable GPSD and it works. Any help how to get NMEA data from the u-blox m8n while using Openploter would be great. Also can the baud rate of the u-blox m8n be configured for 10hz ?

NAVIO+ sems to be nice to use also for boats, not only for " High Fly " :smile:

You can use “ublox-spi-to-pty” or “ublox-spi-to-tcp” utilities to pass data to GPSD. They are available here:

10Hz is available for GPS-only mode. You can configure it using U-center or by manually passing a command to the chip. The instructions for connecting to onboard GPS using U-center are here:

I compiled and run the ublox-spi-to-pty and run it - /dev/pts/1 is created., then run sudo gpsd /dev/pts1 after that, running gpsmon gives:

tcp://localhost:2947 JSON slave driver>
(115) {“class”:“VERSION”,“release”:“3.11”,“rev”:“3.11-3”,“proto_major”:3,“proto_
minor”:9,“remote”:“tcp://localhost:2947”}
(64) {“class”:“DEVICES”,“devices”:[],“remote”:“tcp://localhost:2947”}
(154) {“class”:“WATCH”,“enable”:true,“json”:false,“nmea”:false,“raw”:2,“scaled”:
false,“timing”:false,“split24”:false,“pps”:true,“remote”:“tcp://localhost:2947”

If I run the U-blox Neo example (Navio/C++/Examples/GPS) I wan seeeee the datastream, but get no fix, but that could be caused by the NAVIO board/ raspberry is positioned inside my office.

Hi !

I’m still struggling to get the navio+ onboard gps to connect to gpsd using raspian/openplotter.

  • I’m able to connect to the GPS from a remote pc using u-blox u-center and the github Navio/Utilities/ublox-spi-totcp

  • I’m able to successfully run the provided example to capture ubx protocol messages github Navio/C++/Examples/GPS and this example runs fine and displays data correctly.

  • I’m not able to successfully get nmea date when using Github Navio/utilities/ublox-spi-to-pty. The virtual serial port is created when I run ublox-spi-to-pty but when I conect GPSD to the created port running sudo gpsd /dev/pts/1 and then after that try to use gpsmon to check, there is no position data and it seems that it is no connection to the gps.
    Any hint about how to configure raspbian so that the NAVIO+ onboard gps a starts at boot time and output nmea data to gpsd would be great.

Can you check in u-center if nmea messages is enabled on the spi interface?

I’m able to get NMEA messages if using Navio/Utilities/ublox-spi-to-tcp and connecting to the virtual serial port so NMEA messages is enabled. The problem is to get GPSD to work.

In that case, can you try gpsd on the tcp port of Navio/Utilities/ublox-spi-to-tcp?

It helped a lot to read this page Docs » Navio for developers » Using default Raspbian

Still struggling to get GPSD to work with the provided example bus since the rest now work this seems to be not related to the navio+ module.

I didn’t have any issues getting gpsd to work, but that was a while back.