Navio 2 Barometer Problem

Hello Emlid

I’m having trouble with my navio 2 barometer. My results are as the pictures. I tried with different Rasperry but couldn’t fix the issue. I have rp3 under it. There is nothing else in my I2C port. As I read from forums first I need to suspect from connections but my screws are fit and all pins are in touch. I double checked with my multimeter.

Barometer with C;

Barometer with python ;

Navio looks like that on my setup

Then I try to run apm from putty sometimes it give me that error and not starts it ;

PANIC: AP_Baro::read unsuccessful for more than 500ms in AP_Baro::calibrate [2]

When I tried to run it a few more times it starts with bad baro results.

Do you have any idea what is wrong and how can I fix this problem?

Thanks for support.

Could you please run i2cdetect -y 1?

Yes sure here is the result;

Is there a chance you have ArduPilot running alongside examples?

Try sudo killall ArduCopter-quad (or the like) and launch examples once more.

1 Like

I reinstalled emlid image and install and update apm then try with and without ArduPilot now results are better. it changes ± 1 meter on hub display without foam. I’ll try with foam now.

Thanks for your quick support.

There is one more thing I need help. I checked docs but couldn’t find a clear info. I want to start apm with tcp telemetry and external gps. What should I add to rc.local file ? I’m tring to run with ;

sudo ArduCopter-quad -A -B udp:

but it shows me telemetry datas or something like that;

I have Tallysman multi-GNSS antenna for onboard gps and 3DR uBlox GPS with Compass Kit. I want to use uBloxes compas to avoid High Internal Compass Offsets and I want to use both GPS module. Could u help me to find best startup command ?


I suggest using UDP.

sudo ArduCopter-quad -A udp: -E /dev/ttyAMA0

This command should get two GPS modules working. The compass is already detected as you can see with HC5843: External compass detected

Thanks a lot.
it works with 2 gps now. But I still have some questions about compases.

Which compas should I select as primary to use uBloxes compas ?

When I run live calibration and move only the external compas none of values changes. they changes only when I moves the board. Is it related with IMUs ?

Is there any way to accept UDP connections from any ip adreses? I cannot use static IP on my gcs so everytime I need to change this code for new IP adreses.

I have been fighting Compasses, both internal and external for the last 2 weeks. As usual it was user error, this is what i did to solve (Benedikt actually is the one that solved my problems, i am just trying to give back some of the help i got here):

1 - make sure you run Onboard Mag Calibration on open field and away from metal objects of any kind (don’t bother with live calibration in MP because it is broken)

2 - EVERY TIME you make a change to the compasses, such as wich one is primary or wich one to use, make sure you resart the system, otherwise changes will not be taken in consideration.

3 - If you are using a 3DR external compass make sure you add ROTATION ROLL 180 because the magnetometer is under the pcb (rolled 180°)