Navio 2 and Raspberry Pi 3 wifi issues (SOLVED)

Ladies/ Gents,

I have been able to use the Pi’s wireless adapter to connect via my home router. However now that I’ve installed the Navio 2 I can’t seem to access it using ssh anymore. The only way I can access it right now is through the ethernet connection which has created a new IP address.

Any takers out there?


No one has experience in this?

On top of that, I cannot connect the mission planner over UDP. I’ve followed instructions in the Docs but have not been able to figure it out… I really need the help guys.


I can’t offer a solution but I am having the same problem with the WIFI connection. Using the standard Jessie image I can connect to my home router but with the EMLID image I can not. Ethernet still works but would like to connect to the Pi3 wirelessly.


I can’t move forward with my build at all… read read read and get no where

What about udp? Do you use it or do you use traditional telemetry modules? I thought I could set UDP up and Mission planner would recognize it over the internet without the need for tradtional telemetry modules.

Thanks for piping up, this is a ghost town lol

I don’t use APM at all, just custom code. I have a python UDP script working over ethernet (and I’m assuming it will work over WIFI once that is up and running) but kind of useless at the moment since I can’t fly with an ethernet cable attached. Just out of curiosity, have you tried using a USB WIFI adapter instead of the built-in one? It’s on my list of things to test but haven’t gotten around to it yet.

Yes actually I have. I purchased a Belkin N300F9L1002 this morning to try since it was one on the “supported list”

and tried this method per docs:

There are a few ways to configure Raspberry Pi to connect to your WiFi network. First, it is necessary to connect a supported USB dongle. Raspberry Pi supports a lot of WiFi dongles, the most common ones are based on RTL8192\8188 chipsets, Ralink chips are also widely supported. An extensive list of supported dongles is available here.

Wi-Fi networks can be configured by editing the /boot/wpa_supplicant.conf file located on SD card. To add your network simply add the following lines to it:


this got me no where as well. I installed the firmware updated the pi and set my SSID and Passkey and was still not found when looking for it. Just like when I unplug the ethernet cable the Navio goes inactive

I just put this command from Ethernet connected terminal and reboot.
pi@navio:~ $ wpa_passphrase “my SSID” “my pass code” | sudo tee -a /etc/wpa_supplicant/wpa_supplicant.conf

I actually literally just got it going wirelessly via the steps above minus the key_mgmt=WPA-PSK, then performed reboot. Up and going now! Just need to get this UDP config figured out now! Thanks for the support y’all!

Make that 2 things corrected today. UDP up and going now too!