Navio+ 0 pwm output

I’m experiencing 0 output on navio+ pins, my qbrain 4x25a esc says throttle signal is abnormal (also when the quadcopter is armed and throttle is high/low). Although with my servo tester the esc and motors work fine.
I’ve also tried with a LED, which doesn’t glow at all on whatever pin or polarity i put it on. I’ve tested with both mission planner and the servo example from the docs. Although the LED glows with my servo tester.
I’ve tried the same thing with a voltage measurer and got equal results.

i’m using the newest version of emlids navio+ os, Mission Planner 1.3.50 and APM:Copter V3.4.6
Here’s a picture of my setup:

And a link to my current missionplanner params:

This could be bad coding or just a hardware issue, i don’t know because i’ve experienced inaccuracies with battery measurements aswell.


Could you please post the output of sudo emlidtool? I’m also interested in the content of /boot/config.txt

I see A,B,C leds are glowing even though ArduPilot doesn’t use them at the moment.

Could you please elaborate on this one? How exactly do you test it?

Thanks for the response i really appreciate it
output from “sudo emlidtool” after disabling ardupilot on boot because it told me too:

pi@navio:~ $ sudo emlidtool
emlidtool version: 0.8.8
Vendor: Emlid Limited
Product: Navio+
Issue: Emlid 2017-03-23 5e28de2c424cadfb61a62b88e9c0af98a6d25545
Kernel: 4.4.36-a7765e7-emlid-v7+
Trying to run tests
Testing all sensors
2017-11-03 14:48:09 navio root[824] INFO ms5611: Passed
2017-11-03 14:48:09 navio root[824] INFO mpu9250: Passed

More elaborate description of the LED testing:

I did this for all pins on the navio board and the lamp never lit up. Considering that the current only goes one way through an LED it’s alot of combinations!
The wierd thing about this is that it lit up with my servo tester, when put between + and signal pins.

If you want me to run anymore checks just tell me!

Excellent point, during my first two pictures (in this thread) i was connected to missionplanner.
Although in the following one i was not but the A and C LEDs are still glowing:

You’re using an old image. Please, update to Stretch and try again. I hope it’s alright.

I’m still confused about A,B,C LEDS.

Will do and i’ll report back if i have further issues

This topic was automatically closed after 100 days. New replies are no longer allowed.