My next problem: RC failsafe does not work on FRSKY D4R-II

Hello again,

as always, i now have a problem setting up the RC failsafe. I am using Turnigy 9XR Pro with a FRSKY DJT transmiter and the popular FRSKY D4R-II receiver.
I was more that confident that everything would work straight ahead, because the procedure I follow in the Enable RC Failsafe! link you provided , also shows a video example that uses the same receiver… I do exactly what it says which is extremely simple. Even with such simple procedure, my RC failsafe does not work. Before trying to set the RC failsafe i already succesfully performed radio calibration…
I confirmed that RC failsafe does not work by doing in my desk office the following:

  • arming the motors in stabilize mode and with the throttle being in zero i turned off the transmitter, The mission planner kept showing armed status.
  • arming the motors in stabilize mode and with the throttle in middle i turned off the transmitter. THe mission planner kept showing stabilize mode and motors were still armed. THe motors kept spinning after closing the transmitter

So whats the problem here???
I already tried and used the command that you proposed in another topic sudo cat /sys/kernel/rcio/rcin/ch2
So

  1. I turned on both the receiver and the transmitter and moved the throttle stick up.
  2. i then ran the command sudo cat /sys/kernel/rcio/rcin/ch2 . It returned a pwm value e.g around 1500
  3. then i closed the transmitter and ran the command again. It returned again the same value around 1500.
    Obviously the RC failsafe does not work at all…

Please could you help me ??

THanks and Regards,

Hi,

I too am having similar issues with FRSKY receiver, but i have the D8R-XP, trying to set a no pulses failsafe.
I am seeing the same behavior when using the cat command on the raspi/navio2, only my throttle is mapped to /sys/kernel/rcio/rcin/ch0. I am using a Taranis X9D+ transmitter.

I have tried the procedures described at these to links to set a no pulse failsafe.

http://www.rcgroups.com/forums/showthread.php?t=1666666&page=11
http://www.frsky-rc.com/support/Details.php?fqa_id=554

The only failsafe I have managed to set is setting my throttle to 50% and setting the flight mode to RTL on the transmitter. This mimicks what I want APM to do, but APM is still not aware that a failsafe has occured with this method, I did this by;

  1. Rebinding the receiver
  2. Turn transmitter off
  3. Turn receiver off
  4. Turn receiver on
  5. Turn transmitter on, wait to connected
  6. Set throttle to 50% and set RTL flight mode on transmitter. Use the failsafe screen in missionplanner to verify these are set
  7. Press the FS button on the receiver, a during of ~ 0.5 seconds seams to work.

So when I turn the receiver off, I can see in the Missionplanner Failsafe screen that the throttle changes to 50% and the RTL flight mode is selected. This is not the most ideal, I would rather have no pulse failsafe set and let APM deal with it, but this is as close as I can get. Having spent too many hours on it, it will have to do!

Cheers,

Stu.

ok THank you for the reply.

However i would prefer to make this RC failsafe work as it should… WIthout workarounds. We just have to find the problem…
Lets wait for a reply from the support… Maybe there is a bug hidden somewhere …

Regards,