Must Contain X Photos error; folder does contain X photos

Hi, I’m using Emlid Studio 1.8, MacOS 14.5. Base station was an RS2+. Drone was a Mavic 3 Enterprise receiving RTK connections from the base station.

I can do the “Processing” part of Drone Data Processing fine, but when it comes to geotag the photos, I get an error saying the folder “Must contain 808 photos.” The folder I pointed it to contains 808 photos. Myself and the software are now at an impasse.

I cannot continue and Studio doesn’t give me any additional information as to why it’s throwing a fit. What’s up with it? Thanks!

Update: I tried on a different machine this morning: a Windows desktop. I tried two different projects, one with 808 photos, the other with 1315, and I got the same error each time. Both folders contain the correct number of photos, but the error doesn’t go away or allow me to continue. I do not know what could be wrong, but it’s looking like something with the data itself, but the error is unhelpful in narrowing down what it might be.

Any ideas?

Hi @sdmacdonald,

Welcome to the community forum!

I tested it on my Mac, and it looks like when you open info about the folder, it shows you not only the number of the items inside it but also counts the folder itself. So for the folder with 40 photos, it showed me 41 items in total. You can open the folder, tap Cmd+A, and then Cmd+I. This way, it showed me 40 items, which is a fair number.

If you double-checked it, and 808 is the number of the photos only, can you please check that there are no broken photos or perhaps hidden files in the folder? I’d also ensure that you don’t have special symbols in the names of the images or the path to the folder.

If you have checked it all, but it doesn’t help, please send me one of your datasets at I’ll take a look into it. To attach the files, you can use Google Drive or WeTransfer.

1 Like

Just to double check you do have the right number of jpegs present, just use your mouse to highlight & select the .jpg files only and check you do get 808 or 1315. Also, Make sure you don’t have any extra image files (such as .dng) or .jpeg) in there too. If you’ve access to the microSD card from the drone, then double check you’ve copied everything off, when you’ve done that then use quick preview to quickly skim through the jpgs and make sure they all open & that one of them isn’t corrupted.

Out of interest, what Mac computer/processor are you using?

No broken photos. No corrupt files. No hidden files. The photos are the only thing in the folder.

Every project I’ve tried does this. I think at this point there’s something wrong with our base station or its logs. Maybe it just isn’t set up correctly. My current theory is that the base station and the drone photos are using different timestamps/metadata and the software is checking the photo metadata before it will allow me to proceed.

Does that geotag section check the timestamps or other metadata of the files or photos before allowing it to process? It’s obviously doing more than just counting the number of photos in a folder. **Can you tell me what exactly the software is checking when you point it to a folder full of photos? **

Thank you for the assistance!

Hmm, Emlid Studio should just check the number of files in the folder. I received an email from you with the dataset, thank you. I’ll take a look into it and write you back.

1 Like

I’ve checked the data, and everything seems ok to me. The logs are good, all the time marks are processed in FIX, and the number of photos is proper. So let me discuss this case with our devs.

1 Like

Hi @sdmacdonald,

We’ve checked your dataset with the devs. The reason for the issue was that the folder with photos contained 136 hidden files, which looked like this:


After removing them from the folder, everything can be geotagged fine:

We will think whether such files can be ignored in the future. But for now, they need to be removed manually.


Thank you! I figured it was something simple like this. Those files didn’t show up in either MacOS or Windows (even with show hidden files enabled; I also used Terminal to check) and it wasn’t until I uploaded everything to Google Drive that the hidden files showed up. Some dumb OS thing. Anyway, thank you so much for running this down. I really appreciate it.


Yay! Happy to help :smiling_face: