Multiple error messages

I am new to using navio 2 and mission planner. I have gotten everything setup up and have been using MP to configure my drone. Recently everything has been working great. I can see the telemetry stats fine and have been able to arm the drone. Just last night i have gotten a prearm message saying “Bad gyro health”. this appeared after i had calibrated the esc through MP. Im using the q brain as my esc.

I read online that it could have been a problem with the 3.3v regulator so I powered it up tonight with the micro USB through the RPI 2, just the navio 2 and RPI 2 nothing else attached. I am now getting “Pos. Vert Variance” / “Bad AHRS” / “Bad baro health” / “bad compass health” / no 3D FIX etc. each time I reconnect to the navio. The light on the navio is flashing yellow, when before this happened it was green. Now I also can’t calibrate anything. The HUD in MP just spins around like it is getting erroneous telemetry data.

Is there anything I can do?


I disabled the compasses and turned off auto declination. That seems to have resolved the issues I was having, for now. Could the compasses have gone bad some how? Still concerned about the “Bad gyro health” message though.

since you have so many error messages, my first (guess) question would be:
Is the connection between navio and rpi tight enough to rule out a mechanical issue? (all 4 screws and spacers attached firmly?)

can you explain what happens?

you did fly your drone? what flight mode?

At the time when I was getting those errors. I tried to calibrate the accelerometer and it kept failing. That issue was resolved when I disabled the compass.

As for the screws and standoffs they are tight.

I had not flown it yet, but telemetry was working great.

I havent flown it yet because I was working on getting the motors to calibrate and run at the same time. One motor seems to not want to spin until 1/3 throttle was applied.

have you calibrated your esc’s?
if one motor behaves completely differently after esc calibration - maybe that motor is faulty; check if the shaft is straight and it’s not being blocked by any small pieces inside…i usually had these misbehaveours when that motor had a crash or pieces inside; as soon as your ready to fly - check that motor for temperature; it might fail soon…
(but accelerometer calibration fail is not linked to compass use, it usually occurs when you wobble to much while accepting points)

I have tried to calibrate the motors but Im not sure if Im getting into the calibration mode. How do you tell if you are in the correct mode. It also seems like the motors are at really high rpm when they start. Its not gradual.

ESCs should be calibrated - they control the motors; range of input signal from your autopilot is actually being calibrated;
usually ESCs beep in a special way to tell that they are in calibration mode (sound is ESC-dependent)

-make sure your props are not on your motors
-set ESC_CALIBRATION to 1 (mission planner full parameters list)
-put your remote controller to throttle high
-reboot your navio by removing power and power it again;
“your ESCs should beep several times after reboot”
-put throttle to low on your remote control after you hear your ESC’s beeping
"ESC’s should beep again" (usually once and long)
calibration should be completed!