Ms56111: Failed -- Reason: No connection! abc: Failed -- Reason: Tramp

I am trying to set up ArduPilot. I run into my first issue when i try to update RCIO firmware. I try to update it and it does, then I reboot the system with “sudo reboot” restart PUTTY (the remote app i am using) and then when i try to set up ardupilot it prompts me to update RCIO again! this is shown below.

) if I try to setup ardupilot without updating it is a nightmare and really makes me think i broke my navio2. The errors i get are shown below.

I read some of the other topics regarding setup and i think some people had issues because they did not screw the navio2 onto the raspberry pi tight enough but as you can see below I have done just that.

Is there anything you guys can do for me? Please let me know, thanks!

Hi Fredric,

May I ask you to post here the output of the following commands?

  • readlink -f /usr/bin/arducopter
  • readlink -f /usr/bin/arduplane
  • readlink -f /usr/bin/ardurover


Thank you so much for responding to my post!

When I input the commands you gave me the following appears.

pi@navio:~ $ sudo emlidtool ardupilot
pi@navio:~ $ readlink -f /usr/bin/arducopter
pi@navio:~ $ readlink -f /usr/bin/arduplane
pi@navio:~ $ readlink -f /usr/bin/ardurover
pi@navio:~ $

I actually did see a similar thread where you helped someone with the same issue. In that thread the solution to the problem seemed to be re-flashing the micro SD card. I re-flashed my micro SD card and then I had a networking problem. I believe this was due to my battery being low. when I charged my battery PUTTY seemed to work correctly. This time, when I pulled up ardupilot it did not prompt me to update it. instead it took me right to the setup window. For some reason it only gave me one issue. I tried it a few seconds later and no error. It worked!

So maybe I didn’t give the navio2/raspberrypi enough time to get setup? can you think of any other reason why this can happen?

do you know why it prompted me to update and then would not update when I flashed it the first time?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.