MPU9250 :unexpected WHOAMI 0XFF

NAVIO2 with raspberry pi 3

how to deal with it?

I haved try to cheange a raspberry 3 board,but it is no change

Could you please post a picture of your Navio2 with Raspberry Pi? Did you fix it with screws?

it’s my navio2 with raspberry 3

Does the RGB LED work?

Please run the following commands and post their output.

uname -a
sudo i2cdetect -y 1

it’s my output.
RGB led is working ,but wen I run the demo ,only red yellow and green can show

Could you please check if the issue is not with contact between the boards? Just try to remove Navio and put it back again.

I have used the multimeter to test the contact between the boards,and The connection between them is very good

Please send an email with the order number to and a link to this thread, we will arrange you a replacement.

Hello, Actually i’m going under the exactly same problem.
I’m using raspberry Pi2 + Navio2,

uname -a
Linux navio 4.4.6-4d0ae01-emlid-v7+ #3 SMP PREEMPT Wed Apr 6 13:25:26 MSK 2016 armv7l GNU/Linux

and i have same output above with ‘sudo i2cdetect -y 1’

i checked ‘ps -ef’ and ArduCopter-quad was not working,
and i thought navio shield does not get enough power.
So, i tried power with RC Battery to navio shield and it does change nothing.
It was working well before, and i don’t know why now it’s not working properly.

Is this issue not solved yet?


P.S. ArduCopter-quad process dies after it logs “MPU9250: unexpected WHOAMI 0XFF”.

I checked the hardware status,
I think MPU does not work and only LSM works now.

This is how my raspberryPi2 + Navio2 are connected.
It worked well and i flighted it several times.

Now, i’m giving power only through raspberryPi2 (5V).
Also, i tested to power through navio board. but nothing changed.

it seems there is at least one screw missing to pull navio2 down to raspberry; you should make sure navio2 is screwed down tightly to rpi;

[also, when you use usb, make sure you have enough power (receiver and usb is powered by rpi)]

hey, I think maybe the navio2 board have some perblems ,last time they send a new board to me

You know, i didn’t expect it to recover and i thought the MPU on the board died.

Anyway, after several try, it now works… and i don’t know why…

I think there’s some reason MPU does not work sometimes,


You really should install the fourth screw that holds Navio2. It is very important to have board securely fixed for all sensors to work properly. By the way, why do you have a radiator on the MCU? Is it overheating?