I have a navio plus, rpi b, qbrain esc, the esc is connected to navio which is connected to the rpi.
My problem is that i cant start the motors, i have conneceted to navio over udp and i have a mission planner session, it sayes connected on mission planner.

Thats how i connected the esc to navio

The signal pins are the innermost ones. You have to turn around the ESC connectors.

I Tried that and i still doesnt work. When i tested the motors in apm it said: "command denied by autopilot"
I am running both sides as root

You also should check where you connected your motors. All connectors on the navio are labelled. It looks like you connected the ESCs to Aux, ppm, 1 and 2. I did not notice this at first, the picture was to small on my smartphone. Aux is for an external BEC and ppm for rc receiver.
Maybe it would be a good idea to read through the docs again.

1 Like

Thanks for all the help,
But its still not working, it still says “command denied by the autopilot”

Did you do all the initial setup calibrations?
There are prearm checks enabled per default and if any of them is triggered the copter will not arm.
If you want to fly without rc, you have to disable rc prearm check.
How did you fix the RPi to your copter? It looks like it is just lying on the top plate of your copter. There are metal screws heads everywhere, they may shortcircuit your RPi.
Follow the emlid docs and the instructions on Everything you need to do is covered there.

ok, i will try that