Motors spin after apm starts - Faulty Navio2 I think

I’m trying to get my quad setup but am running into a problem with my navio2.

After I power on and wait for the Pi to start, APM starts (I’m guessing from the LED lights). After apm starts up, all four motors start spinning, slow, like barely able to keep it that low, but still spinning. I can arm them and disarm them normally, but they never stop spinning.

In addition to this the gimbal isn’t working right either. Everything is configured exactly how I had my Navio+ last week but now I’m getting these issues.

I have tried recalibrating the ESCs 2 times but still the same issue.

Just an update, I tried uninstalling and re-installing apm and still the issue is there. When I ssh, the motors start the spinning as soon as I start APM and stop as soon as I stop APM.

Another update. I am getting power through the servo rail from the power module. Isn’t this not supposed to happen? I thought I had to power the servo rail using a bec. I can unplug the bec, plug in the power module and the radio receiver (connected to the PPM part) still receives power. Is this a faulty board? could this be part of the issue why my motors are spinning once arduCopter starts?

One last update. Now, when I plug in the bec into the servo rail it causes the navio2 AND raspberry pi to shut down. But I can still plug the bec straight into the radio reciever and use a esc calibration thing to test the motors and they work as expected.

I think I have a faulty board.

Are you running any channels in passthrough mode? There is currently a bug with that mode.

This is a feature. We are powering receiver from the power module, so that you don’t have to use BEC for that. The rest of the servo rail is not powered from the power module.

I’m not sure what passthrough mode is, but I did try to set the 5th pin set (and then 7th to see if it changed) to a gimbal. I first set it to say “servo” because I think that is what I did on the navio+ to get it to work. Is that considered passthrough mode?

What about the bec causing the navio and pi to shut down and not start? Is that part of the same issue with passthrough?

Any workarounds?

This should not happen. Can you provide pictures of how you plug it in and how everything is connected?

I’ll take pictures when I get home from work.

Here is brief overview. ESC’s are plugged into 1,2,3,4. They only have a signal and ground. But the extentions I’m using make it look like there are all three. But the power part isn’t plugged into anything.

Pin group 5 I tried to plug in the gimbal, again, it will look like all three cables are there but it is only the signal cable that actually gets to the gimbal.

In the last group of pins (I forget the number) was where I had the 5v from the bec going.

the only other thing plugged into the navio is the power module cord from my power module (an aftermarket one that can handle 6s).

I found the same issue. For now, I either disable the gimbal, or set RC_SPEED=50 and restart Arducopter.

However, a lower RC_SPEED definitely makes the copter more sluggish.

See [Solved] Erratic motors which is very similar.

Let me know if either disabling the gimbal or setting a low RC_SPEED helps.

If you do not enable the gimbal, do you still see the issue? As @pierig correctly pointed out there is an issue with that currently. We are working on it.

It seemed to start when I enabled the gimbal but disabling doesn’t fix it.

Also, sorry for the delay but here is a picture:

Edit: Ugh, sorry that its blurry. Right most (colored cable) is the rc, then the 4 motors, then gimbal. Last is the 5v from BEC.

Since the BEC seems to short everything out when I plug it in, I’m going to try a new one.

Today after work I’ll try changing the settings that pierig suggested.

Looks like your ESCs are with positive wire (red) connected for all (4 escs).

Are these ESCs opto ? Otherwise you have to cut the red wire from 3, and keep only one, or cut all of them , and use a BEC (recommended)

IF you already have the bec you have to cut red wire from all ESCs )

but is difficult to see in the picture.

ya, I tried explaining about that earlier, sorry that the picture isn’t as clear as it could be. I only saw it was blurry once I was already at work.

Anyways, the parts you see there are just exentions, the actual ESC cable only has signal and ground.

These are the motors I have, you can see in two of the product pictures what I mean, that there is only ground and signal (black/white).

http://www.hobbyking.com/hobbyking/store/__82874__Black_Widow_3508_400Kv_With_Built_In_ESC_CW_CCW.html

Clear, sorry…

did you check the BEC voltage? (because just a little over can be a problem) only to double check if its ok. did you have the problem without bec and guimbal ?

and if you connect only the ESCs and motors without Navio board to the battery (without the signal wire to Navio), are they spin ?.

I haven’t checked the BEC yet, I was planning to.

I can connect the motors to the battery and the ESCs to a calibration thing and connect them to the throttle channel on the receiver and they work normally.

The spinning starts as soon as I start ardupilot.

ok, clear.

But happens without BEC and Guimbal?

one more question, if you power off and power on everything happens ? or only with sudo reboot ?

and only to double check , set your MOT_SPIN_ARMED parameter to ZERO, “no spin” in APM paramenters.

without BEC and Gimbal plugged in, they still spin as soon as arducopter starts.

The symptoms start anyway that arducopter starts, whether its a sudo reboot or a complete powerdown.

I still need to try the suggestions that were mentioned above though, to actually disable or change the values.

After set your MOT_SPIN_ARMED parameter to ZERO, “no spin” in APM paramenters
Other thing, is recalibrate all ESCs , using APM. (WITHOUT PROPELLERS)
never can spin without ARM - really , really dangerous…

  1. Push the throttle to maximum (first),
  2. Power on Navio and wait the APM start.
  3. Turn off the baterries
  4. Power on Navio again and wait the APM start.
  5. Push the throttle to minimum (sound beeps)

Disabling the gimbal or changing the rc_speed fixed the issue.

Thank you for your help. Will the update be software based or will I need to submit the board in?