Motor does not work properly on Raspberry Pi 4B

I changed my drone from a Raspberry Pi 3 to a 4 in order to increase processing speed and use USB 3.0. After that, I checked the rotation of the motors using RC and found an anomaly: the rotation of the motors in two places gradually weakened and stopped. Can you tell me the cause of this? Also, is NAVIO2, which I got before Raspberry Pi 4 came out, compatible with Raspberry Pi 4?

  1. Image and ArduPilot version.
    Image)https://files.emlid.com/images/emlid-raspbian-20200922.img.xz
    ArduPilot)Copter 3.6.9 and Copter4.0.7 (I tried it with both)
    Raspberry Pi)Raspberry Pi 4 model B 4GB

  2. Detailed problem description. How does expected behavior differ from the observed one?
    Normally, all the motors should be spinning at the same speed, but two of the motors were spinning weakly and stopped after a while.

  3. Your step by step actions.
    I changed the NAVIO2 to something else with the same result, and I can confirm that there is no problem with the ESC.

  4. Screenshot with the error.
    Video of one motor stopping.

Hi @kakiuchi.aislab,

Welcome to the community forum!

It’s quite hard to understand the cause of it at the moment. Have you performed ESC calibration? Were there any errors?

Yes, Navio2 supports the usage of RPi 4; there should be no issues with it.

Can you share what device it was? Also, please specify the exact make and model of the ESC that you’re using.

Thanks for the reply.
ESC calibration is working fine. All motors are spinning the same way. I recently changed the ArduCopter version to 4.0.0 and was able to fly the drone without any problems. The motors were spinning fine. The ESC I am using is an ARRIS 30A Simonk.

Hi @kakiuchi.aislab,

Thanks for the details!

Looks now that the issue is related to a particular version of ArduCopter. Do the motors work fine on ArduCopter 4.0.3? The one that is preinstalled on the latest Navio2 image.