Mobile Data is Flaky

Hello,

I have had inconsistent performance with the mobile data turning on when turning on the Reach RS2+. My day to day setup is to physically set up/turn on the base station unit in the same location (within 1 meter) each day. Once the lights stop blinking on the unit, I always connect via hotspot to make sure the survey process has started. Then I wait for the configured 20 minutes to get a single solution (auto-survey) for the coordinates. After that time has passed, sometimes the mobile data turns on and sometimes the mobile data refuses to turn on. This is apparent because the toggle switch in the Emlid Flow app in Settings->Mobile Data does not turn on. When I try to tap the toggle switch, it will turn lighter gray for a short while but then goes back to its “off” color/position after a few seconds. It never switches over to the blue on position. I also don’t see the bars next the battery icon(see image). I am using a Verizon sim card in the Emlid and I verified on my phone (which also uses Verizon) that I have 4 out of 5 bars. So I have a few questions:

  1. What are the requirements for that toggle switch to come on?

  2. Does connecting to the Emlid via hotspot during the auto-survey process somehow “lock up” the mobile data?

Here is a picture showing that the mobile data is not on. See the missing bars next to battery icon.

Hi Andres,

Welcome to the forum!

From our investigation, it looks like there’re some restrictions from Verizon’s side that don’t allow it to work well with RS2+.

Do I understand correctly that you’re in the USA? We know that, some of our users from the USA successfully work with AT&T (data+voice plan) and EIOTCLUB/Twilio/SPECTRUM SIM cards.

2 Likes

Hi Olesia,

Yes, I am in the US. Just as some additional feedback, after several (~4) consecutive failed attempts using the process described above(connecting via hotspot through the app while averaging for the single solution), I tried restarting the unit and NOT connecting via hotspot at all (both during the averaging step and after the single solution was found) and each time (two times) was successful in having the mobile data turn on as expected.

Another data point, is that when I turn the unit on near wifi (and connect through the app on WIFI mode) the mobile data successfully turns on even though it hasn’t found a single solution(because its indoors and not getting signal from satellites).

Andres,

Do I understand correctly that you don’t connect to the Reach device after turning it on, wait till the Fix solution and then connect to the device in Emlid Flow? Please share a screen recording of how it looks from your side.

Do I understand correctly that you don’t connect to the Reach device after turning it on, wait till the Fix solution and then connect to the device in Emlid Flow?

Sometimes that works, but not all the time. I’ve had most success just by never connecting to the app via hotspot. Instead, I check that the mobile data is on by checking that it comes online on https://caster.emlid.com/ after waiting for the expected time for the solution.

My suspicion is that there is something that locks up mobile data when connecting with the Emlid Flow app via hotspot. The mobile data almost always turns on reliably when connecting via wifi which isn’t on option in many outdoor locations.

Andres,

Thank you for explaining your workflow! I just wanted to add that from the Reach side, we don’t have restrictions for any SIM card providers.

2 Likes

Another data point from today: At startup, at the beginning of the day, I used the same process as described in this thread (never connecting with the app via hotspot). After four hours of flawless performance running with the ntrip caster (using mobile data), I was curious to check the status in the app. As soon as I connected to the device via the app, the status in https://caster.emlid.com/ switched to “offline.” In the app itself, the mobile data showed as off. And my rover was reporting lost RTK.

There is definitely a bug when using mobile data and connecting to the Emlid via hotspot. To be clear, its not hotspot mode itself because the device works just fine out of range of any wifi connection (the light is white, not blue). It’s only when you connect to the device with the app that the mobile data locks up. I’m also on the latest firmware.

For now, the work around is to configure the Emlid base unit with the app when needed, but during normal day-to-day operation DO NOT connect with the app after restarting/ turning on the device.

Andres,

Thank you for sharing this workaround. It could be helpful for other users.

1 Like

Another data point from today: Using the previously described methods, the Emlid base station unit did not come online after several (~4) attempts. This was away from wifi so it initialized in hotspot mode. I moved the unit to an area near wifi, it initialized and come fully online as expected. Then I moved it back to the normal operation location away from wifi (again in hotspot mode) and then it came online using the previously described methods. It seems that the mobile data connectivity is well tested in wifi mode but not in hotspot mode. Please keep me updated on any firmware updates that fix this. Thank you!

1 Like

Andres,

Does the issue occur only with Verizon SIM card? If yes, it looks like the limitations from the Verizon provider side I advised earlier. I’ve also double-checked Reach with the Telekom SIM card and haven’t experienced any issues with the disconnection.

I don’t know how it functions with other sim cards. All my experience has been with a Verizon sim card.

Without even opening up the app on my phone, the “mobile data offline” happens even when my cell phone connects to the base station’s hotspot because of the “auto-reconnect to wifi” setting on my phone. This happened twice (on different days) while walking near the station after hours of being in an online status. My phone was locked on both occasions and the emlid app was not open.

@olesia.riman
In the case that the unit is near WiFi, why is the mobile data even needed? If the unit can connect to the internet via WiFi, then you shouldn’t need a sim card (mobile data) to use the ntrip caster feature at all.

Andres,

If the Reach unit is connected to Wi-Fi (blue Network LED), the SIM card isn’t needed. It can be removed or turned off, and you should still see your receiver online in the Emlid Caster. Do you experience anything different? Do you not see the base online? If yes, is the base set up in the Emlid Flow?