Mission planning causing telemtry lost

Dear community,

Recently I have a major problem with my mission planning and my telemetry from the rover to my PC and controller. The problem is that when I run my mission planner and want to drive a mission on GPS the rover goes nuts and just drives around and my telemetry to my PC and controller is lost. When this happens I am not able to stop the rover with my pc and not even with my controller.

The strange thing is that I had it all working and this is a problem since today.

My question is if someone knows why or how this could happen, and what I can do to fix it.

Thanks in advance!

Could you please describe your hardware setup in details and provide some photos of how everything is connected in the rover?

Here is the list of components you asked for:
• Raspberry Pi 2
• Navio +
• Tallysman multi gnss antenna
• FR sky D4R , for the connection with the controller
• 2 high torque motors
• 1 servomotor
• 1 accu
• 1 ESC to control the voltage for the motors
• 1 IEEE 802IN 300W wireless usb adaptor for WIFI connection

We changed the hardware setup 2 days ago because we would make sure the ESC or something else could not cause the problem. I’ll add the pictures below:


thanks in advance

I like your chassis, may I ask where you got it as I’ve been looking for a good rover chassis for a project.


How do you connect APM and Mission Planner?
Also, where is the GPS antenna located?

I connect my APM with WIFI to mission planner.
And my GPS is placed on top of the case, see picture below:

Is the problem repeatable indoors?

  1. Fixate the rover
  2. Start APM
  3. Connect Mission planner (do you use UDP or TCP btw?)
  4. Try to switch to auto mode
    is the connection from Mission Planner to APM is lost in this case?

yes the problem is repeatable indoors and outdoors.
We connect de rover by UDP to mission planner. And yes when the telementry is lost and he just drives around I also lose the connection with mission planner.

Do you have a telemetry radio to try with instead of WiFi?

yes we have but that messed it up even more. And we had it working a few weeks ago but then our SD card crashed. After we bought a new SD card and did everyting again we got all these problems.

Please do the following test:

  1. On your Raspberry Pi run raspi-config and enable serial console
  2. Connect one radio to UART on Navio and another to your computer
  3. Configure radios for 115200 baudrate
  4. Open terminal on your computer (RealTerm on Windows, “screen /dev/ttyUSB0 115200” on Linux) and make sure you are able to access Raspberry Pi console on the terminal (you see boot messages and login prompt)
  5. Connect to Raspberry\Navio over WiFi and run APM as usual, then run auto mission.

What happens on the console after that? Is it still accessible? If yes, do you see APMRover process running (run “top” in the console)?

We have tried it with Radio to UART. We got the same problems as before. We also did the full configuration of the raspberry and the navio again. This also didn’t help. The compas directs in the wrong way and when he has to drive on a mission plan he just drives around.

I was not suggesting to connect telemetry over radio, I was suggesting accessing Linux console over radio (if WiFi stops working) and checking the system state (is Linux responding, is APM process running).

I want to clarify this - does the WiFi connection stops or does it keep working? I mean connection on its own, not UDP connection to the GCS. e.g. can you SSH into RPi when this happens?

no we couldn’t SSH into the RPI when this happend but we now only use radio connection. We disconnected our wifi and removed our WIFI adapter, we hoped that maybe this caused our problems but it wasn’t causing it.

Then please try what I described in the earlier post and share the results.