Mission planner

Hi ,
I am trying to integrate reach with my Navio 2. So for now i have connected my Navio2 with reach through Uart and on the Usb my 3Dr 915mHz radio goes. My laptop is connected with the other radio 915Mhz. my base reach is also powered and connected and working. I am giving this command sudo ArduPlane -C /dev/ttyUSB0 -E /dev/ttyAMA0 and connecting through COM5 by 57600. Although the connection is made between the APM and NAVio but when i am trying to click load settings on Sik Radio Invalid Comport in use command is coming. and neither i am able to access the Sik Radio and how do I disable Mavlink connection cause I haven’t donw that. Can someone please help me out in this

The error message is saying it all: You use the comport for mavlink communication, so you can not use it for SiK radio configuration at the same time. Disconnect Missionplanner via the connect/disconnect button in the top right and try again with SiK configuration.

thanks @schuermannsebastian , I figured out how to connect the two 3DR radio . but I cannot connect my two reach. Their is no grey bars coming indicating that my base and rover are communicating. I have followed the docs given for Pixhawk . i have connected as follows. I just dont know what i am missing.

I can not help you with reach itself, but you should only use 4 wires to connect reach to the uart. There are two GPIO pins exposed in the Navio2 uart connector and a 6pin cable might mess up communication. All pins are labelled on the underside of the Navio.

thanks @schuermannsebastian ,
Is the command that I am giving sudo ArduPlane -C /dev/ttyUSB0 -E /dev/ttyAMA0 right? Does it matter if i change USB0 to USB1 ? does the position of 3DR radio in my USB slot matters?
and can please explain what does it mean by second GPS argument?

Nope. The name given to a special file like /dev/ttyUSB0 depends solely on the order you plug a device in a Raspberry.

So, well. yes, it does matter, because there might be no /dev/ttyUSB1.

Run dmesg on the Raspberry, eject the 3DR radio, dmesg and you’ll see something like /dev/ttyUSB0 unregistered, plug into again, dmesg. I hope it’s clear now.

Ok, you @george.staroselskiy were faster, but anyways:

In Linux, ttyXXX devices are the serial ports/consoles. USB devices can be many things, but in our case it is another serial/uart port. The first serial device you plug into USB gets the designation ttyUSB0, the second ttyUSB1 and so on.
So it does not matter in which USB port you plug the 3dr radio in, but there might be no ttyUSB1 device.

The different startup options are used to tell APM what to do.

-A is the primary telemetry connection, usually used for network telemetry (but not limited to that). In the APM config it runs with 115200baud per default (serial0), so most telemetry radios (57600baud) do not work with that option, without adjusting the settings.

-B is used to replace the onboard GPS with an external one.

-C is the secondery telemetry option, usually used for telemetry radios and configured for 57600baud (serial1) per default.

-D (unused?)

-E is used for a dual GPS setup, with the internal and an external GPS.

I read a comment in the HAL_Linux_class.cpp, mentioning APM running on Linux just supports three serial ports at the moment. So that would be it.

1 Like

Thanks @schuermannsebastian and @george.staroselskiy , I actually got it working after i took out two GPIO pins from the reach. thanks

Sorry to revive an old thread, but this one seemed most helpful to me so far.

I think I wish to construct my /etc/default/arducpter file so as to be able to connect to Mission Planner on my windows desktop (this is currently the only way I’m connecting) in my office via UDP (not sure what UDP is, but it’s working) then connect to Mission Planner on my windows laptop in the field. I say I think because I will also be providing GPS corrections through the same radio and I’m a little fuzzy on all the connections.

I’m doing something wrong.

Before attempting to connect, I set up Sik radio and both screens propagate with data from the radios.

with the second Radio attached and listed as COM4 on my laptop, baudrate is 57600, when I click on connect, Mission planner plug/connected icon switches from red plug and connect to green plug and connected but Connecting mavlink dialog shows a countdown to timeout, then error “No Heartbeat Packets /Received”

Attached is my current /etc/default/arducopter file:


Fixed IT, Replaced the white USB wire that came wih my reach unit with a short usb I had already. Voila, Connected!

Also, I’ve successfully added Reach and achieved RTK fix through NTRIP using Mission Planner connection. When you say [quote=“schuermannsebastian, post:7, topic:4379”]
-B is used to replace the onboard GPS with an external one.
Do you truly mean replace or just add a second one? I would like to replace so as not to have two GPS antennas on my Copter but I was under the impression using the reach as primary GPS was not recommended.