Mission Planner extremely slow downloading logs

I have a problem, when i try to download a log from the board in mission planner it takes ages.

Can the logs be downloaded from mission planner as in other boards? In case it can be done do you have any hints on why it take sso long?

My board is connected to PC trough wifi.

Maybe navio stores the logs somewhere and i can just download from there and review in mission planner?


The logs are stored in /var/logs/APM/. I use WinSCP to download them.

Tried and it works great, Thanks.

Do you use Mission Planner to convert from bin to log?


I never converted anything. Missionplanner should be able to open the bin files.

It does open them, thanks a lot.


@Corrado_Steri & @schuermannsebastian and any gurus in here Hi all,

Am using Navio2 Flight board, am trying to download datalog with mission planner but it took too long to download and finally “Error in log Timeout on read” - GetLog

please can you help me what code to put before “The logs are stored in /var/logs/APM/. I use WinSTP to download them.” so as i can download the log files or any approach i can use

Sorry, I just noticed I wrote WinSTP instead of WinSCP. I corrected my post.
WinSCP is a file explorer. It lets you connect to your Raspberry Pi just like Putty does, but you get a graphical user interface, to copy files from the RPi to your PC and vice versa. Local (PC) filestructure is on the left, RPi filestructure on the right. “var/logs/APM/” is the path where the logs are stored on the Rpi.

@schuermannsebastian okey, let me work on that then i will feed you back

Thanks @schuermannsebastian for your help, i could be able to SSH into the RPi3 but the result i got is different, look From%20winSCP

, one from Mission Planner that has Logdata that i want to download of 1st may and another one is from WinSCP that i dont see the same data as what i have seen in Mission planner. I connected the Navio2 with Mission Planner while is being SSH with WinSCP

You are in var/log/apt instead of var/logs/APM.

But once i used to navigate to /var/APM/logs/ i found files with .bin format but looking like they are the same like .log or does the log siles in Navio2 being stored in the form of .bin?, i think they are these files that i am looking for, @schuermannsebastian with you we save the the world through open forum, thanks to Navio Community to put us together.

I didn’t find the path that you gave me /var/logs/APM

Sorry my fault again. :frowning: My brain seems to take vacations from time to time, without telling me…
The correct path is the one you found: var/APM/logs
Yes, the .bin files are the ones you need to download or copy to your PC.

Thanks for noticing, @schuermannsebastian together we build the open platform better to server the world of Drone technology to better the world development through the open platform, Thanks again to all the Emlid community

it happened to me, i was trying to download over radios, takes forever, but once tried via USB it flies.

2 posts were split to a new topic: Downloading Mission Planner logs