Missing time marks during Post Processing

HI All
Any one noticing that during post processing, some of the time events are missing?

For example, on download of the log, I got the message:
Log start time: 2016-08-18 07:29:36
Log stop time: 2016-08-18 08:08:14
Navigation messages parsed:
Messages inside: GPS nav: 66, SBAS log: 1999, Obs: 11362, Time marks: 386

After post processing, the event file that was created has only 383 records in it. There are no “time start/end” limits as I am using the entire log. I can see the missing 3 events in the plot view, and they appear to be random.
Many thanks

1 Like

Hi Luke,

Note that currently you should not use SBAS when processing with RINEX3.x. If you need to use SBAS, please use RINEX2.x . We will look into this issue soon.

If this does not help, please send me your logs and we’ll see what is wrong.

If anyone is feeling particularly keen, here is some raw data:
Rover: https://www.dropbox.com/s/09cwxtiui45uxi2/Rover.zip?dl=0
Base: https://www.dropbox.com/s/p9t2s9zobcxznm3/Base.zip?dl=0

HI Igor, nor sure why it includes SBAS as we are not recording it. Default Reach Single config using GPS and GLONASS at 10hz. We do not use it for processing.
Would be great to see if you get more answers than me!

I mean if you remove SBAS tick in rtklib processing options. Is it what you did?

How many pictures do you actually have from that flight?

Yes, We do not use SBAS here in Deep Africa! Also was not set as an option on the Reach
We have 386 images.
I have identified where those missing 3 positions are.

Will try to reproduce the issue. Thank you for the report!

Seems like we already fixed that, but it did not make it into the build. We will update them in about 1-2 weeks.

Hey Luke!

We’ve updated our RTKLIB branch, including the time mark functionality. The previous build ignored time marks if the solution was bad at the time they happened. Now they appear with a warning.

I have post-processed your logs on RTKLIB with all the latest patches(default settings though) so you could check it out. The pos file and the events file.

I will update the link to time-mark-enabled RTKPOST in the docs later today.

Awesome, many thanks.

Well, I’ll try to process my own data until I saw I couldn’t use time mark. Events file is not here.
I use rtkpost qt under linux and rtklib 2.4.3 b8 from here https://github.com/JensReimann/rtklib-qt/blob/rtklib_2.4.3_qt/readme.txt
So should I use only your rtklib version 2.4.3 b16 or it’s possible with rtklib 2.4.3 b8 build for QT and cross platform ?
I want to you use your commits with QT, so which branch should I use ? This one : https://github.com/emlid/RTKLIB/tree/emlid_2.4.3 ?

Edit : Ok I didn’t notice you have already embeded Qt on your branch. But I tried to build with gcc 5 and 6 and get an error :
RTKLIB-emlid_2.4.3/src/solution.c:1544: undefined reference to `outerb’
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:314: rtknavi_qt] Error 1

Any idea ?

Hi @Sylvain_POULAIN, you should use the version that we provide in the docs, as only it has the time mark extraction functionality.

You can use CLI utility Rinex2rtkp under Linux, which is the same as RTKPOST.

QT support is a experimental in RTKLIB, so I can’t provide help with the error, sorry.

Thank you, I run it with wine for the moment …
Qt version is working very well but I have only the b8 working. I need to investigate

I had another run in with a single missing timestamp today. The ReachView version is v0.4.9 and the RTKPOST is Ver.2.4.3 b16 from the special Emlid flavour.
If anyone is keen, here is the data:


Event #26 seems to be missing.
Using only GPS and Glonass.

Hi Luke,

Here’re your .pos flight and event files (279.9 KB) processed in RTKPOST ver 2.4.3 b26.
There was a bug in b16, due to which you can’t process a file without losing a point.

We’ll post b26 today a bit later.

1 Like

Excellent! Thank you so much. Not to worry, with 549 images with VERY precise coordinates(thanks to Reach and a flash sync cable), Pix4D was able to accurately determine a camera location for the missing mark.
Look forward to your flavour of RTKLib today.

Reviving a little old topic but I have a little bit similar problem with post-processing positions of camera triggering events: I have absolutely no event mark positions in the post-processed _events.pos file.

I’m using Reach Image v2.3 on my both units, ReachView app is upgraded for most recent v2.2.7. I’ve checked that the right (Time mark) pin on Rover Reach is pulled up to 5V from 0V when camera takes a photo (a similar cable was built like Tuffwing cable to power Reach and pull up Time mark pin simultaneously). On my base configuration I use for my trials Single averaging for base position calculation and Static mode; for rover simply Kinematic mode is used. Can this configuration cause problems during post-processing?

I went through Post-processing tutorial several times (both rtkpost_emlid_b26.exe and rtkpost_emlid_b27.exe were tested), checked parameters in Options maybe I missed something but it not helped. Although, it’s interesting that regular rover positions were processed flawlessly.

Any idea what I’m missing?

1 Like

@messer.janos ReachView has a real-time indicator for timemarks in Camera tab, did you check if it works there?

1 Like

@igor.vereninov Thank you for your help, I checked it but it seems to me that it does not work. Connected battery to my quadcopter, waiting for Single position and triggered event with the transmitter manually but Last time mark says nothing. Should I wait longer to calculate time based on GPS?

Should I switch on Camera trigger option on the left side in ReachView to activate this indicator? I think they are independent functions. I opened up my 3D printed case to check soldered pins on DF13 but it’s rock-solid, there is no broken pins or solder joints.

What can be the problem?

1 Like

It should actually be the opposite. Hotshoe pulls pin to the ground when triggered.

They are independent.